summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-06-06 22:26:34 +0000
committerYixun Lan <dlan@gentoo.org>2024-06-06 22:26:34 +0000
commitfa5a1030ccac534c69d83d98d133ab856723bf91 (patch)
tree858283c5ad9efdf0bc7e42d990337ca26788231f /www-apps
parentwww-apps/gitea: Stabilize 1.21.11 amd64, #933701 (diff)
downloadgentoo-fa5a1030ccac534c69d83d98d133ab856723bf91.tar.gz
gentoo-fa5a1030ccac534c69d83d98d133ab856723bf91.tar.bz2
gentoo-fa5a1030ccac534c69d83d98d133ab856723bf91.zip
www-apps/gitea: drop 1.21.8, 1.21.10
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitea/Manifest2
-rw-r--r--www-apps/gitea/gitea-1.21.10.ebuild147
-rw-r--r--www-apps/gitea/gitea-1.21.8.ebuild147
3 files changed, 0 insertions, 296 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 227226bcbe66..81b1ecd7eb69 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,4 +1,2 @@
-DIST gitea-1.21.10.tar.gz 53972181 BLAKE2B 564e5ee1b7ddb737dc35a712810c3958788457a307db51ecf84fc65b2a69f6b21110e134172c64693cc4bd49c3c6243d4444328ae9a9724e81b06f09df7cd279 SHA512 3129a1b379308195725906fd3c12722099e51662e56e3f488e5114bd531c71f9319e6f170cd227660a1a7f4d30d4d88686b4fc74c28f040d4c9b1a4c6acfba9b
DIST gitea-1.21.11.tar.gz 54029294 BLAKE2B 93fb0ea4118baefeb36283b7168759d318fede528b56a9167961763267181bb283bf9849ce5f57a9950b16047f3b98998b4cd0e92443a23aef4cf15589cc8628 SHA512 ba35d1710bc03ff05bf2490e233bf3b4bd9e002113885b4d2a3193288773c16ad0f2426d4ed64d26b7c49112a02838e67da32167f51c4c08fa4f23738bd78285
-DIST gitea-1.21.8.tar.gz 53901461 BLAKE2B e20f509037e5bb674696fb9bdc9b3eb58443f0481f5db2936a69775adcd8c1b53ad7103bae6ba4de2e852ef50218b8bd89dae174d19e0879d04f169e890af71b SHA512 e895d67ab0c086fdef6aab6548ed06696054bb0a8103818c14f5f038a6fc6310178473038fa76752341a50196916ce3845b785f25ab66383bdf44ce8eac87461
DIST gitea-1.22.0.tar.gz 54603268 BLAKE2B f021fedf77ec6ab41221a8e73d6b48fc215c15053bb62ff288a5dc6a7d11a5acd4d7ee0cbfb40aee2b60011d83fc57f1011013b7d78556c3a84a2743ba90389b SHA512 8e9585d6224f49c2f21b855911c2ac4ded64b8b31c4eb28fbe39801908693a87aad2e9096bf812c30163faa8a8102fd01ec3240bd64debf5633c70568aec4b49
diff --git a/www-apps/gitea/gitea-1.21.10.ebuild b/www-apps/gitea/gitea-1.21.10.ebuild
deleted file mode 100644
index 7a37bd3df1e3..000000000000
--- a/www-apps/gitea/gitea-1.21.10.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 2016-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
-else
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
-fi
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-BDEPEND=">=dev-lang/go-1.21:="
-
-DOCS=(
- custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags
- local -a gitea_settings makeenv
-
- # The space-separated list of the -tags flag is deprecated, please
- # always use the comma-separated list in the future.
- gitea_tags="bindata"
- gitea_tags+="$(usex pam ',pam' '')"
- gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
-
- gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
-
- makeenv=(
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags}"
- )
-
- if [[ ${PV} != *9999 ]]; then
- # Use variable STORED_VERSION_FILE (the "${S}/VERSION" file) to set version,
- # and prevent executing git command when it's not a live version.
- makeenv+=( GITHUB_REF_NAME="" )
- fi
-
- if use pie ; then
- # Please check the supported platforms when a new keyword request opened,
- # refer to file: 'go/src/internal/platform/supported.go'.
- # When PIE buildmode is not supported by internal linker, the external
- # linker will be used automatically, refer to:
- # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
- makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
- fi
-
- env "${makeenv[@]}" emake backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
- # but for convenience, the tmpfile uses the git user and group by default.
- # To avoid installation errors, a condition needs to be added here:
- # if there is no git user or group, the installation of tmpfile will be skipped
- # and the user will be notified to handle it by themselves.
- if egetent passwd git &>/dev/null && \
- egetent group git &>/dev/null; then
- tmpfiles_process gitea.conf
- else
- eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
- eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
- eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
- eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
- eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
- eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
- eerror "to install it."
- fi
-
- if [[ -n ${REPLACING_VERSIONS} ]] && ver_test "${REPLACING_VERSIONS}" -lt 1.21; then
- ewarn "Since 1.21.0:"
- ewarn " 1. The built-in SSH server will now only accept SSH user"
- ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
- ewarn " 2. The options of the subcommand must follow the subcommand now."
- ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
- fi
-}
diff --git a/www-apps/gitea/gitea-1.21.8.ebuild b/www-apps/gitea/gitea-1.21.8.ebuild
deleted file mode 100644
index df7f876a0823..000000000000
--- a/www-apps/gitea/gitea-1.21.8.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 2016-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps go-module tmpfiles systemd flag-o-matic user-info
-
-DESCRIPTION="A painless self-hosted Git service"
-HOMEPAGE="https://gitea.com https://github.com/go-gitea/gitea"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/go-gitea/gitea.git"
-else
- SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv ~x86"
-fi
-
-S="${WORKDIR}/${PN}-src-${PV}"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
-SLOT="0"
-IUSE="+acct pam sqlite pie"
-
-DEPEND="
- acct? (
- acct-group/git
- acct-user/git[gitea] )
- pam? ( sys-libs/pam )"
-RDEPEND="${DEPEND}
- dev-vcs/git"
-BDEPEND=">=dev-lang/go-1.21:="
-
-DOCS=(
- custom/conf/app.example.ini CHANGELOG.md CONTRIBUTING.md README.md
-)
-FILECAPS=(
- -m 711 cap_net_bind_service+ep usr/bin/gitea
-)
-
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i -e "s#^MODE = console#MODE = file#" custom/conf/app.example.ini || die
-}
-
-src_configure() {
- # bug 832756 - PIE build issues
- filter-flags -fPIE
- filter-ldflags -fPIE -pie
-}
-
-src_compile() {
- local gitea_tags
- local -a gitea_settings makeenv
-
- # The space-separated list of the -tags flag is deprecated, please
- # always use the comma-separated list in the future.
- gitea_tags="bindata"
- gitea_tags+="$(usex pam ',pam' '')"
- gitea_tags+="$(usex sqlite ',sqlite,sqlite_unlock_notify' '')"
-
- gitea_settings=(
- "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
- "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
- "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
- )
-
- makeenv=(
- LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
- TAGS="${gitea_tags}"
- )
-
- if [[ ${PV} != *9999 ]]; then
- # Use variable STORED_VERSION_FILE (the "${S}/VERSION" file) to set version,
- # and prevent executing git command when it's not a live version.
- makeenv+=( GITHUB_REF_NAME="" )
- fi
-
- if use pie ; then
- # Please check the supported platforms when a new keyword request opened,
- # refer to file: 'go/src/internal/platform/supported.go'.
- # When PIE buildmode is not supported by internal linker, the external
- # linker will be used automatically, refer to:
- # https://github.com/golang/go/blob/ed817f1c4055a559a94afffecbb91c78e4f39942/src/cmd/link/internal/ld/config.go#L149
- makeenv+=( EXTRA_GOFLAGS="-buildmode=pie" )
- fi
-
- env "${makeenv[@]}" emake backend
-}
-
-src_install() {
- dobin gitea
-
- einstalldocs
-
- newconfd "${FILESDIR}/gitea.confd-r1" gitea
- newinitd "${FILESDIR}/gitea.initd-r3" gitea
- newtmpfiles - gitea.conf <<-EOF
- d /run/gitea 0755 git git
- EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
-
- insinto /etc/gitea
- newins custom/conf/app.example.ini app.ini
- if use acct; then
- fowners root:git /etc/gitea/{,app.ini}
- fperms g+w,o-rwx /etc/gitea/{,app.ini}
-
- diropts -m0750 -o git -g git
- keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
- keepdir /var/log/gitea
- fi
-}
-
-pkg_postinst() {
- fcaps_pkg_postinst
-
- # It is not guaranteed that the git user and group always exist (due to the acct USE Flag),
- # but for convenience, the tmpfile uses the git user and group by default.
- # To avoid installation errors, a condition needs to be added here:
- # if there is no git user or group, the installation of tmpfile will be skipped
- # and the user will be notified to handle it by themselves.
- if egetent passwd git &>/dev/null && \
- egetent group git &>/dev/null; then
- tmpfiles_process gitea.conf
- else
- eerror "Unable to install the tmpfile for gitea due to the git user or group is missing,"
- eerror "please install tmpfile manually or rebuild this package with USE flag 'acct'."
- eerror "You can simply copy the default tmpfile from '/usr/lib/tmpfiles.d/gitea.conf'"
- eerror "to higher priority path '/etc/tmpfiles.d/gitea.conf', and correct it with"
- eerror "the right User and Group value (see tmpfiles.d(5) for details), then execute:"
- eerror " # systemd-tmpfiles --create /etc/tmpfiles.d/gitea.conf"
- eerror "to install it."
- fi
-
- if [[ -n ${REPLACING_VERSIONS} ]] && ver_test "${REPLACING_VERSIONS}" -lt 1.21; then
- ewarn "Since 1.21.0:"
- ewarn " 1. The built-in SSH server will now only accept SSH user"
- ewarn " certificates, not server certificates. This behaviour matches OpenSSH."
- ewarn " 2. The options of the subcommand must follow the subcommand now."
- ewarn " 3. Remove 'CHARSET' config option for MySQL, always use 'utf8mb4'."
- ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.21.0>."
- fi
-}