summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-09-28 22:18:00 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-10-01 19:21:29 +0300
commitcea42a65013a85aedbd84b33bfb42f386a3ff5fa (patch)
tree6f39cc72802dcfc665a9436629ee18e7d047c01d /www-apps
parentsys-block/tgt: add 1.0.88 (diff)
downloadgentoo-cea42a65013a85aedbd84b33bfb42f386a3ff5fa.tar.gz
gentoo-cea42a65013a85aedbd84b33bfb42f386a3ff5fa.tar.bz2
gentoo-cea42a65013a85aedbd84b33bfb42f386a3ff5fa.zip
www-apps/rutorrent: bump version to 4.2.6
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/33112 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-4.2.6.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index 5f87ef9396c4..70e79a73e6eb 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1 +1,2 @@
DIST rutorrent-4.1.6.tar.gz 2256263 BLAKE2B 7767d4c79473239303cda844e95804e5ff02bae3a037e83caf619c02fb16172057226d426d1b8ba7155dc8dc8602d59a631f9336271979d463bf7478cfa529a1 SHA512 e6c38712c1cb2836fe5172212294382431832359dec9f60f2654d5ce934a7ff3164b86b846db5db0541737d1133e1bbc7c61e688e28f02eece3837cd1d201d1a
+DIST rutorrent-4.2.6.tar.gz 2360873 BLAKE2B 810dc7e237114df6f013b2a663c29ea581c27518415f6abb0c8ae0648bb18a352caa236bc877627d2145833c7e23cf39d55c15221285598d1a05ab223c3fed7d SHA512 0c561ae738f88990e1d374ad55de02cd9e842a9a674a6dd221711a8f52e1ce2ce627e151461fcf7286a8459960dc897858f24c2fe3671f705ed90b63f60123fb
diff --git a/www-apps/rutorrent/rutorrent-4.2.6.ebuild b/www-apps/rutorrent/rutorrent-4.2.6.ebuild
new file mode 100644
index 000000000000..f7dbb6ae40d3
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-4.2.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp optfeature
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Novik/ruTorrent.git"
+else
+ SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+ S="${WORKDIR}/ruTorrent-${PV}"
+fi
+
+LICENSE="GPL-2+ MIT"
+
+RDEPEND="
+ dev-lang/php[xml,gd]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ rm -r .github || die
+ find . \( -name .gitignore -o -name .gitmodules \) -type f -delete || die
+ if [[ ${PV} == 9999 ]]; then
+ rm -r .git .gitattributes || die
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # can not use fperms beacuse of globbing
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "${ED}${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ keepdir "${MY_HTDOCSDIR}"/conf/users
+ keepdir "${MY_HTDOCSDIR}"/share/settings
+ keepdir "${MY_HTDOCSDIR}"/share/torrents
+ keepdir "${MY_HTDOCSDIR}"/share/users
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/conf
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/share
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "Show audio file spectogram" media-sound/sox
+ optfeature "Display media file information" media-video/mediainfo
+ optfeature "Scrape Cloudflare based sites" dev-python/cloudscraper
+}