summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-09-05 07:15:34 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-08 08:51:35 +0200
commit7a5f6b9152762348a8e2b6b052d92656dbffc5f1 (patch)
tree17bd3323df20bc1805dc18d147b67d6e9d74b94b /www-apps
parentdev-ruby/psych: don't install internal binstubs, fixing bug 593068 (diff)
downloadgentoo-7a5f6b9152762348a8e2b6b052d92656dbffc5f1.tar.gz
gentoo-7a5f6b9152762348a8e2b6b052d92656dbffc5f1.tar.bz2
gentoo-7a5f6b9152762348a8e2b6b052d92656dbffc5f1.zip
www-apps/kibana-bin: improve ebuild.
* Bump to EAPI 6. * Fix indent. * Add missing die()'s. * Remove double slashes. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2241 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/kibana-bin/kibana-bin-4.6.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/www-apps/kibana-bin/kibana-bin-4.6.0.ebuild b/www-apps/kibana-bin/kibana-bin-4.6.0.ebuild
index 4923fede8429..4ab82a638bb4 100644
--- a/www-apps/kibana-bin/kibana-bin-4.6.0.ebuild
+++ b/www-apps/kibana-bin/kibana-bin-4.6.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit pax-utils user
@@ -28,9 +28,9 @@ pkg_setup() {
src_unpack() {
if use amd64; then
- S="${WORKDIR}/${MY_P}-linux-x86_64"
+ S="${WORKDIR}/${MY_P}-linux-x86_64"
elif use x86; then
- S="${WORKDIR}/${MY_P}-linux-x86"
+ S="${WORKDIR}/${MY_P}-linux-x86"
fi
default
@@ -43,7 +43,7 @@ src_install() {
insinto /etc/${MY_PN}
doins config/*
- rm -rf config
+ rm -rf config || die
insinto /etc/logrotate.d
newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
@@ -51,14 +51,14 @@ src_install() {
newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
newinitd "${FILESDIR}"/${MY_PN}.initd-r3 ${MY_PN}
- mv * "${D}"/opt/${MY_PN}
+ mv * "${ED%/}"/opt/${MY_PN} || die
# bug 567934
- pax-mark m "${ED}/opt/${MY_PN}/node/bin/node"
+ pax-mark m "${ED%/}/opt/${MY_PN}/node/bin/node"
}
pkg_postinst() {
- elog "This version of Kibana is compatible with Elasticsearch 2.3+"
+ elog "This version of Kibana is compatible with Elasticsearch 2.4+"
elog
elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
elog "in /etc/conf.d/${MY_PN}."