summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-21 14:34:11 +0100
committerSam James <sam@gentoo.org>2021-02-22 22:18:33 +0000
commit14c2ba836f554d5ed5858ca6fb765729ae51256d (patch)
tree13e84f4f5a9a76c3895a23773c08d0970a56f3fd /www-apps
parenteclass/toolchain.eclass: disable USE=vtv on gcc-10 and above (diff)
downloadgentoo-14c2ba836f554d5ed5858ca6fb765729ae51256d.tar.gz
gentoo-14c2ba836f554d5ed5858ca6fb765729ae51256d.tar.bz2
gentoo-14c2ba836f554d5ed5858ca6fb765729ae51256d.zip
www-apps/novnc: Port to python 3.9
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/novnc/novnc-1.2.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/www-apps/novnc/novnc-1.2.0.ebuild b/www-apps/novnc/novnc-1.2.0.ebuild
index d055a2d70452..02803bff38ac 100644
--- a/www-apps/novnc/novnc-1.2.0.ebuild
+++ b/www-apps/novnc/novnc-1.2.0.ebuild
@@ -3,14 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
HOMEPAGE="https://kanaka.github.com/noVNC/"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
else
@@ -21,10 +20,8 @@ fi
LICENSE="LGPL-3"
SLOT="0"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
dev-python/websockify[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]"