summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/websvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/websvn')
-rw-r--r--www-apps/websvn/Manifest2
-rw-r--r--www-apps/websvn/metadata.xml8
-rw-r--r--www-apps/websvn/websvn-2.3.2.ebuild54
-rw-r--r--www-apps/websvn/websvn-2.3.3.ebuild54
4 files changed, 118 insertions, 0 deletions
diff --git a/www-apps/websvn/Manifest b/www-apps/websvn/Manifest
new file mode 100644
index 000000000000..fcd2980632c4
--- /dev/null
+++ b/www-apps/websvn/Manifest
@@ -0,0 +1,2 @@
+DIST websvn-2.3.2.tar.gz 846511 SHA256 d2e6e65c1ca8c51e036b2229f144fe22cd13c005a080326a99eef48453855bdc
+DIST websvn-2.3.3.tar.gz 882779 SHA256 67d5cb7ffb087f8a92e3dcad10f16612baac4d15a60d659aa8b6e06200ac8742 SHA512 8c77a9770dfc3c9487793cd71c460d4048aa4aa7b8520a53eea8ae872f30e06d885f849d63fa0e9f61ed5923f9dd9c5ef1f3c4f020afaa83d7815a99d64818a0 WHIRLPOOL efd59ddbe6a84d2b0bce9286271627e485c77b93dd0ad998ecaa4bad8bfb246f62508c3e1d6183194b9f64313f223bb44fc8d8fdf0c1f176efb808b3cbf7e7d9
diff --git a/www-apps/websvn/metadata.xml b/www-apps/websvn/metadata.xml
new file mode 100644
index 000000000000..e6d124be11a6
--- /dev/null
+++ b/www-apps/websvn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <longdescription>
+ Web based Subversion repository browser written in PHP
+ </longdescription>
+</pkgmetadata>
diff --git a/www-apps/websvn/websvn-2.3.2.ebuild b/www-apps/websvn/websvn-2.3.2.ebuild
new file mode 100644
index 000000000000..b01c38a14b77
--- /dev/null
+++ b/www-apps/websvn/websvn-2.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit depend.php eutils webapp
+
+MY_P="${P//_/}"
+
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://www.websvn.info/ http://websvn.tigris.org/"
+DOWNLOAD_NUMBER="48737"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+
+DEPEND=""
+RDEPEND="dev-vcs/subversion
+ enscript? ( app-text/enscript )"
+RESTRICT="mirror"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use xml
+}
+
+src_install() {
+ webapp_src_preinst
+
+ mv include/{dist,}config.php
+
+ dodoc changes.txt || die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+ rm -rf license.txt changes.txt doc/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die "doins failed"
+
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}
diff --git a/www-apps/websvn/websvn-2.3.3.ebuild b/www-apps/websvn/websvn-2.3.3.ebuild
new file mode 100644
index 000000000000..f49970f6b98b
--- /dev/null
+++ b/www-apps/websvn/websvn-2.3.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit depend.php eutils webapp
+
+MY_P="${P//_/}"
+
+DESCRIPTION="Web-based browsing tool for Subversion (SVN) repositories in PHP"
+HOMEPAGE="http://www.websvn.info/ http://websvn.tigris.org/"
+DOWNLOAD_NUMBER="49056"
+SRC_URI="http://websvn.tigris.org/files/documents/1380/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+IUSE="enscript"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=""
+RDEPEND="dev-vcs/subversion
+ enscript? ( app-text/enscript )"
+RESTRICT="mirror"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use xml
+}
+
+src_install() {
+ webapp_src_preinst
+
+ mv include/{dist,}config.php
+
+ dodoc changes.txt || die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+ rm -rf license.txt changes.txt doc/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r . || die "doins failed"
+
+ webapp_configfile "${MY_HTDOCSDIR}"/include/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/wsvn.php
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+
+ webapp_src_install
+}