summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-18 14:09:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-18 14:10:34 -0600
commit36c099bfc38a921ca4382fea09efa62a95a76ae2 (patch)
treee4b33f9e661f2872dcde2f127eb83ffb3fd9c9a1 /www-apps/novnc
parentmedia-plugins/gimp-resynthesizer: bump to 2.0.3 (diff)
downloadgentoo-36c099bfc38a921ca4382fea09efa62a95a76ae2.tar.gz
gentoo-36c099bfc38a921ca4382fea09efa62a95a76ae2.tar.bz2
gentoo-36c099bfc38a921ca4382fea09efa62a95a76ae2.zip
www-apps/novnc: fixing bugs, and an eapi bump
Closes: https://bugs.gentoo.org/644914 Closes: https://bugs.gentoo.org/644910 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/novnc-0.6.2-r1.ebuild47
-rw-r--r--www-apps/novnc/novnc-9999.ebuild47
2 files changed, 67 insertions, 27 deletions
diff --git a/www-apps/novnc/novnc-0.6.2-r1.ebuild b/www-apps/novnc/novnc-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..fb8b22ba491e
--- /dev/null
+++ b/www-apps/novnc/novnc-0.6.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ echo
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r *.html include/ images/
+ dosym images/favicon.ico /usr/share/novnc/favicon.ico
+}
diff --git a/www-apps/novnc/novnc-9999.ebuild b/www-apps/novnc/novnc-9999.ebuild
index 3bcb1d55fc69..fb8b22ba491e 100644
--- a/www-apps/novnc/novnc-9999.ebuild
+++ b/www-apps/novnc/novnc-9999.ebuild
@@ -1,20 +1,27 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-2
+inherit distutils-r1
DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
HOMEPAGE="https://kanaka.github.com/noVNC/"
-EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
S="${WORKDIR}/noVNC-${PV}"
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND=""
@@ -27,28 +34,14 @@ python_compile() {
}
src_install() {
- dodir /usr/share/novnc/utils
- dodir /usr/share/novnc/include
- dodir /usr/share/novnc/images
-
exeinto /usr/share/novnc/utils
- doexe utils/b64-to-binary.pl
- doexe utils/img2js.py
- doexe utils/inflator.partial.js
- doexe utils/json2graph.py
- doexe utils/launch.sh
- doexe utils/parse.js
- doexe utils/u2x11
-
- docinto /usr/share/novnc/docs
- dodoc README.md
- dodoc LICENSE.txt
-
- cp -pPR *.html "${D}/usr/share/novnc/"
- cp -pPR include/* "${D}/usr/share/novnc/include/"
- cp -pPR images/* "${D}/usr/share/novnc/images/"
- dosym images/favicon.ico /usr/share/novnc/favicon.ico
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
- newconfd "${FILESDIR}/noVNC.confd" noVNC
- newinitd "${FILESDIR}/noVNC.initd" noVNC
+ insinto /usr/share/novnc
+ doins -r *.html include/ images/
+ dosym images/favicon.ico /usr/share/novnc/favicon.ico
}