summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-01-17 14:36:22 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-01-17 14:36:22 -0600
commit345bf4d04e79dd6c5a642c5b223a8b1d4251ec59 (patch)
tree922e8c7f9363c89715c08de6961cee16915620c9 /www-apps/novnc
parentnet-mail/getmail: version bump to 4.53.0 (diff)
downloadgentoo-345bf4d04e79dd6c5a642c5b223a8b1d4251ec59.tar.gz
gentoo-345bf4d04e79dd6c5a642c5b223a8b1d4251ec59.tar.bz2
gentoo-345bf4d04e79dd6c5a642c5b223a8b1d4251ec59.zip
www-apps/novnc: bup fixing xss
Package-Manager: portage-2.3.0
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/novnc-0.6.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
index ba714e992bee..c8b5ed18c0f1 100644
--- a/www-apps/novnc/Manifest
+++ b/www-apps/novnc/Manifest
@@ -1 +1,2 @@
DIST novnc-0.6.1.tar.gz 600681 SHA256 a8cb87a14e38f88a4db604bafc836e809672548086e971fb734862dc9f1bd1cc SHA512 9ea62effd44166553ff93c80bb070df91f70efded922ef43425d3485ed798b7f3b17005c8832c3d0d32ac9c8b095cc4f235fea153ad88055565d8f904ef50e93 WHIRLPOOL 4e1cd767592aeff491a42e9c93784c2db3a319af77b7c6005adc19610fd762c48ed11c3c8adb7ad796daf6965405b95cd187178cf527e21214139a35bd7bdd01
+DIST novnc-0.6.2.tar.gz 600675 SHA256 70a27fe472b901faef7235a61e01aed884ec8c2234a666844acfd9da7e5bcf9b SHA512 245d205f8935c82722a55d6cfcd2cea1825176c0cd695fd0eec34aa19cdc3b766fed62e741ff41b0a8c4a3b3cbabc5a39dfa6ad8ffa6169f5b88420a4a845a7c WHIRLPOOL 2ebbae02d702486674216864ef83c84a1439ee0b52815be423e4ad1bacc1748c57f8b749c4a1a0367bc2485506e2249d79bab13782324bd221314965b8fdd495
diff --git a/www-apps/novnc/novnc-0.6.2.ebuild b/www-apps/novnc/novnc-0.6.2.ebuild
new file mode 100644
index 000000000000..8ea152c36bd9
--- /dev/null
+++ b/www-apps/novnc/novnc-0.6.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ echo
+}
+
+src_install() {
+ dodir /usr/share/novnc/utils
+ dodir /usr/share/novnc/include
+ dodir /usr/share/novnc/images
+
+ exeinto /usr/share/novnc/utils
+ doexe utils/b64-to-binary.pl
+ doexe utils/img2js.py
+ doexe utils/inflator.partial.js
+ doexe utils/json2graph.py
+ doexe utils/launch.sh
+ doexe utils/parse.js
+ doexe utils/u2x11
+
+ docinto /usr/share/novnc/docs
+ dodoc README.md
+ dodoc LICENSE.txt
+
+ cp -pPR *.html "${D}/usr/share/novnc/"
+ cp -pPR include/* "${D}/usr/share/novnc/include/"
+ cp -pPR images/* "${D}/usr/share/novnc/images/"
+ dosym /usr/share/novnc/images/favicon.ico /usr/share/novnc/
+
+ newconfd "${FILESDIR}/noVNC.confd" noVNC
+ newinitd "${FILESDIR}/noVNC.initd" noVNC
+}