summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:03:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 10:03:16 +0200
commit039c68f53c589b56572bdf7081b1ce1227d17e96 (patch)
treeafd75826849a54a6e41f893dfe97d2d6899d83bc /www-apache
parentapp-crypt/openssl-blacklist: Remove last-rited pkg (diff)
downloadgentoo-039c68f53c589b56572bdf7081b1ce1227d17e96.tar.gz
gentoo-039c68f53c589b56572bdf7081b1ce1227d17e96.tar.bz2
gentoo-039c68f53c589b56572bdf7081b1ce1227d17e96.zip
www-apache/mod_scgi: Remove last-rited pkg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_scgi/Manifest1
-rw-r--r--www-apache/mod_scgi/files/20_mod_scgi.conf33
-rw-r--r--www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch49
-rw-r--r--www-apache/mod_scgi/metadata.xml5
-rw-r--r--www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild32
5 files changed, 0 insertions, 120 deletions
diff --git a/www-apache/mod_scgi/Manifest b/www-apache/mod_scgi/Manifest
deleted file mode 100644
index 460c31adcc43..000000000000
--- a/www-apache/mod_scgi/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST scgi-1.14.tar.gz 29406 BLAKE2B 46bf75f9971f8801ae0244bd43ae85730f8c48cc437381937d16f8f7e143302472c4e9e4bf8ce52b1a9732fc77449b95a8f03b785b0c08c48e3a6dc53079ab5a SHA512 148986aab3a5579b7dd7d15583990844149b799df32221b4d2c354b11361f79727087d63ddd54227d2aae937253997774e521606c7baea6b808b9efef025a01a
diff --git a/www-apache/mod_scgi/files/20_mod_scgi.conf b/www-apache/mod_scgi/files/20_mod_scgi.conf
deleted file mode 100644
index 1b7b5962748d..000000000000
--- a/www-apache/mod_scgi/files/20_mod_scgi.conf
+++ /dev/null
@@ -1,33 +0,0 @@
-<IfDefine SCGI>
-LoadModule scgi_module modules/mod_scgi.so
-
-# Apache2 example
-#<Location "/dynamic">
-# SetHandler scgi-handler
-# SCGIServer localhost:4000
-# SCGIHandler On
-# Options -Multiviews
-#</Location>
-#<LocationMatch "^/(dynamic|login)($|/)">
-# SetHandler scgi-handler
-# SCGIServer localhost:4000
-# SCGIHandler On
-# Options -Multiviews
-#</Location>
-#<Location "/foo">
-# SCGIServer localhost:4000
-# SCGIHandler On
-# Options -Multiviews
-#</Location>
-#<Location "/bar">
-# SCGIServer localhost:4001
-# SCGIHandler On
-# SCGIServerTimeout 10
-# Options -Multiviews
-#</Location>
-#<Location "/bar/images">
-# SCGIHander Off
-#</Location>
-</IfDefine>
-
-# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch b/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch
deleted file mode 100644
index 8c1240b18c31..000000000000
--- a/www-apache/mod_scgi/files/mod_scgi-1.14-apache-2.4.patch
+++ /dev/null
@@ -1,49 +0,0 @@
---- a/apache2/mod_scgi.c
-+++ b/apache2/mod_scgi.c
-@@ -135,16 +135,16 @@
- return DECLINED;
- }
-
--static void log_err(const char *file, int line, request_rec *r,
-+static void log_err(const char *file, int line, int index, request_rec *r,
- apr_status_t status, const char *msg)
- {
-- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
-+ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
- }
-
--static void log_debug(const char *file, int line, request_rec *r, const
-+static void log_debug(const char *file, int line, int index, request_rec *r, const
- char *msg)
- {
-- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
-+ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
- }
-
- static char *http2env(apr_pool_t *p, const char *name)
-@@ -312,7 +312,7 @@
- int i;
- apr_status_t rv = 0;
- apr_port_t port = 0;
-- GET_PORT(port, r->connection->remote_addr);
-+ GET_PORT(port, r->useragent_addr);
-
- log_debug(APLOG_MARK,r, "sending headers");
- t = apr_table_make(r->pool, 40);
-@@ -324,14 +324,14 @@
- buf = "0";
- add_header(t, "CONTENT_LENGTH", buf);
- add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
-- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
-+ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
- add_header(t, "SERVER_PROTOCOL", r->protocol);
- add_header(t, "SERVER_NAME", ap_get_server_name(r));
- add_header(t, "SERVER_ADMIN", r->server->server_admin);
- add_header(t, "SERVER_ADDR", r->connection->local_ip);
- add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
- ap_get_server_port(r)));
-- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
-+ add_header(t, "REMOTE_ADDR", r->useragent_ip);
- add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
- add_header(t, "REMOTE_USER", r->user);
- add_header(t, "REQUEST_METHOD", r->method);
diff --git a/www-apache/mod_scgi/metadata.xml b/www-apache/mod_scgi/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/www-apache/mod_scgi/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild b/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild
deleted file mode 100644
index ff52bf450860..000000000000
--- a/www-apache/mod_scgi/mod_scgi-1.14-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit apache-module eutils
-
-DESCRIPTION="Apache module for a replacement of the CGI protocol, similar to FastCGI"
-HOMEPAGE="http://python.ca/scgi/ https://pypi.org/project/scgi/"
-SRC_URI="http://python.ca/scgi/releases/scgi-${PV}.tar.gz"
-
-LICENSE="CNRI"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~ppc x86"
-IUSE=""
-
-DEPEND="~www-apps/scgi-${PV}"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/scgi-${PV}"
-
-APXS2_S="${S}/apache2"
-APACHE2_MOD_FILE="${S}/apache2/.libs/${PN}.so"
-APACHE2_MOD_CONF="20_mod_scgi"
-APACHE2_MOD_DEFINE="SCGI"
-
-DOCFILES="PKG-INFO LICENSE.txt CHANGES.txt apache2/README.txt"
-
-need_apache2_4
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-apache-2.4.patch
-}