summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-27 00:13:33 +1000
committerSam Jorna <wraeth@gentoo.org>2016-04-27 00:17:19 +1000
commit33da93895c529ba8e8deb8dfd52f077c401d06ee (patch)
tree3598641211ccb4260c06102c7d3ebcac4997e82e /www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild
parentwww-apache/mod_xml2enc: assign proxy maintainer (diff)
downloadgentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.tar.gz
gentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.tar.bz2
gentoo-33da93895c529ba8e8deb8dfd52f077c401d06ee.zip
www-apache/mod_xml2enc: bump to 1.0.4, add config
Bumps to v1.0.4 as well as adds an apache modules.d config to enable. Original config file contributed by user Matthew Smith and updated by maintainer Russell Knighton along with version bump. Gentoo-bug: 575410 Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild')
-rw-r--r--www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild b/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild
new file mode 100644
index 000000000000..8b5a6aa77ed5
--- /dev/null
+++ b/www-apache/mod_xml2enc/mod_xml2enc-1.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module to provide libxml2 encoding"
+HOMEPAGE="http://apache.webthing.com/mod_xml2enc/"
+SRC_URI="http://apache.webthing.com/svn/apache/filters/${PN}.h -> ${P}.h
+ http://apache.webthing.com/svn/apache/filters/${PN}.c -> ${P}.c"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/bzip2
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="26_${PN}"
+APACHE2_MOD_DEFINE="XML2ENC"
+
+need_apache2
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ mkdir "${WORKDIR}"/${PN} || die
+ cp "${DISTDIR}/${P}.h" "${WORKDIR}/${PN}/${PN}.h" || die
+ cp "${DISTDIR}/${P}.c" "${WORKDIR}/${PN}/${PN}.c" || die
+}
+
+src_compile() {
+ APXS2_ARGS="$(xml2-config --cflags) -c ${PN}.c"
+ apache-module_src_compile
+}