summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_macro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_macro')
-rw-r--r--www-apache/mod_macro/Manifest2
-rw-r--r--www-apache/mod_macro/files/00_example.conf26
-rw-r--r--www-apache/mod_macro/files/27_mod_macro.conf6
-rw-r--r--www-apache/mod_macro/metadata.xml5
-rw-r--r--www-apache/mod_macro/mod_macro-1.1.10.ebuild31
-rw-r--r--www-apache/mod_macro/mod_macro-1.2.1.ebuild32
6 files changed, 102 insertions, 0 deletions
diff --git a/www-apache/mod_macro/Manifest b/www-apache/mod_macro/Manifest
new file mode 100644
index 000000000000..3b31c3d6ae37
--- /dev/null
+++ b/www-apache/mod_macro/Manifest
@@ -0,0 +1,2 @@
+DIST mod_macro-1.1.10.tar.bz2 13517 SHA256 9ce558d0b182a721a04e5b499ba2684d07c5ba2c7a552d8a844489beb9e339d0
+DIST mod_macro-1.2.1.tar.gz 16870 SHA256 f22c6342b36526fb401dea4dba4c2b61a72083da973b9ca1c4777a77d5128fc3
diff --git a/www-apache/mod_macro/files/00_example.conf b/www-apache/mod_macro/files/00_example.conf
new file mode 100644
index 000000000000..5b60e92ca830
--- /dev/null
+++ b/www-apache/mod_macro/files/00_example.conf
@@ -0,0 +1,26 @@
+# Definition of a MyVirtualHost Macro.
+<Macro MyVirtualHost $host $port $dir>
+ Listen $port
+
+ <VirtualHost $host:$port>
+ DocumentRoot $dir
+
+ <Directory $dir>
+ # do something here...
+ </Directory>
+
+ # limit access to intranet subdir.
+ <Directory $dir/intranet>
+ order deny,allow
+ deny from all
+ allow from 10.0.0.0/8
+ </Directory>
+ </VirtualHost>
+</Macro>
+
+# Use of MyVirtualHost with different arguments.
+#Use MyVirtualHost www.apache.org 80 /projects/apache/web
+#Use MyVirtualHost www.perl.com 8080 /projects/perl/web
+#Use MyVirtualHost www.ensmp.fr 1234 /projects/mines/web
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_macro/files/27_mod_macro.conf b/www-apache/mod_macro/files/27_mod_macro.conf
new file mode 100644
index 000000000000..67ce8e4d2688
--- /dev/null
+++ b/www-apache/mod_macro/files/27_mod_macro.conf
@@ -0,0 +1,6 @@
+<IfDefine MACRO>
+LoadModule macro_module modules/mod_macro.so
+Include /etc/apache2/macros.d/*.conf
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_macro/metadata.xml b/www-apache/mod_macro/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/www-apache/mod_macro/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_macro/mod_macro-1.1.10.ebuild b/www-apache/mod_macro/mod_macro-1.1.10.ebuild
new file mode 100644
index 000000000000..2af2351c0e13
--- /dev/null
+++ b/www-apache/mod_macro/mod_macro-1.1.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module providing macros for the Apache config file"
+HOMEPAGE="http://www.coelho.net/mod_macro/"
+SRC_URI="http://www.coelho.net/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+APACHE2_MOD_CONF="27_${PN}"
+APACHE2_MOD_DEFINE="MACRO"
+
+DOCFILES="CHANGES INSTALL README mod_macro.html"
+
+need_apache2_2
+
+src_install() {
+ apache-module_src_install
+ keepdir "${APACHE_CONFDIR}"/macros.d/
+ insinto "${APACHE_CONFDIR}"/macros.d/
+ doins "${FILESDIR}"/00_example.conf
+}
diff --git a/www-apache/mod_macro/mod_macro-1.2.1.ebuild b/www-apache/mod_macro/mod_macro-1.2.1.ebuild
new file mode 100644
index 000000000000..161663d04e13
--- /dev/null
+++ b/www-apache/mod_macro/mod_macro-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module providing macros for the Apache config file"
+HOMEPAGE="http://www.coelho.net/mod_macro/"
+#SRC_URI="http://www.coelho.net/${PN}/${P}.tar.bz2"
+SRC_URI="http://people.apache.org/~fabien/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+
+APACHE2_MOD_CONF="27_${PN}"
+APACHE2_MOD_DEFINE="MACRO"
+
+DOCFILES="CHANGES INSTALL README mod_macro.html"
+
+need_apache2_4
+
+src_install() {
+ apache-module_src_install
+ keepdir "${APACHE_CONFDIR}"/macros.d/
+ insinto "${APACHE_CONFDIR}"/macros.d/
+ doins "${FILESDIR}"/00_example.conf
+}