summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandy Barlow <randy@electronsweatshop.com>2024-01-30 21:16:33 -0500
committerSam James <sam@gentoo.org>2024-02-10 04:48:55 +0000
commite1e5d0b920146597216a2b1e0b473776b5295272 (patch)
tree41ce33d77d19054f61938f6c7640caa0518ccf99 /virtual/rust
parentsys-devel/rust-std: Add 1.75.0 (diff)
downloadgentoo-e1e5d0b920146597216a2b1e0b473776b5295272.tar.gz
gentoo-e1e5d0b920146597216a2b1e0b473776b5295272.tar.bz2
gentoo-e1e5d0b920146597216a2b1e0b473776b5295272.zip
virtual/rust: Add 1.75.0
Closes: https://bugs.gentoo.org/922880 Signed-off-by: Randy Barlow <randy@electronsweatshop.com> Closes: https://github.com/gentoo/gentoo/pull/35085 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.75.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.75.0.ebuild b/virtual/rust/rust-1.75.0.ebuild
new file mode 100644
index 000000000000..208c9e6ba7a4
--- /dev/null
+++ b/virtual/rust/rust-1.75.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-17"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"