summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2023-08-04 15:19:58 +0800
committerWANG Xuerui <xen0n@gentoo.org>2023-08-04 20:30:26 +0800
commit1ee36a35ed4404e95cb88a69e745580f2a5d0c73 (patch)
tree20d3e96f7b24fee761601598ec190c29d24f0bfc /virtual/rust
parentdev-lang/rust: add 1.71.1 (diff)
downloadgentoo-1ee36a35ed4404e95cb88a69e745580f2a5d0c73.tar.gz
gentoo-1ee36a35ed4404e95cb88a69e745580f2a5d0c73.tar.bz2
gentoo-1ee36a35ed4404e95cb88a69e745580f2a5d0c73.zip
virtual/rust: add 1.71.1
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.71.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.71.1.ebuild b/virtual/rust/rust-1.71.1.ebuild
new file mode 100644
index 000000000000..630588ccee03
--- /dev/null
+++ b/virtual/rust/rust-1.71.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-16"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"