summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-08-11 22:51:53 +0200
committerSam James <sam@gentoo.org>2024-08-11 21:56:01 +0100
commitdf8c8087a90e1123ea8a7e62a10d2be5df9167b1 (patch)
treea2150a280def96b08f227fc36ec45024e160056c /sys-process
parentmedia-sound/lilypond: add 2.24.4 (diff)
downloadgentoo-df8c8087a90e1123ea8a7e62a10d2be5df9167b1.tar.gz
gentoo-df8c8087a90e1123ea8a7e62a10d2be5df9167b1.tar.bz2
gentoo-df8c8087a90e1123ea8a7e62a10d2be5df9167b1.zip
sys-process/atop: patch out uname usage
Bonus: dies when it finds uname in netatop source Closes: https://bugs.gentoo.org/919693 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/atop-2.10.0-r1.ebuild8
-rw-r--r--sys-process/atop/atop-2.9.0-r1.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/sys-process/atop/atop-2.10.0-r1.ebuild b/sys-process/atop/atop-2.10.0-r1.ebuild
index c9b216bc2e3f..5d3ecf36942a 100644
--- a/sys-process/atop/atop-2.10.0-r1.ebuild
+++ b/sys-process/atop/atop-2.10.0-r1.ebuild
@@ -53,6 +53,14 @@ src_prepare() {
if use modules ; then
cd "${WORKDIR}"/${NETATOP_P} || die
eapply "${FILESDIR}"/${PN}-2.9.0-netatop-makefile.patch
+
+ sed \
+ -e "s#\`uname -r\`#${KV_FULL}#g" \
+ -e "s#\$(shell uname -r)#${KV_FULL}#g" \
+ -i {.,daemon,module}/Makefile || die
+
+ grep -rq "uname -r" && die "found uname calls"
+
cd "${S}" || die
fi
diff --git a/sys-process/atop/atop-2.9.0-r1.ebuild b/sys-process/atop/atop-2.9.0-r1.ebuild
index 313f9ab42b41..b7d49a35cd46 100644
--- a/sys-process/atop/atop-2.9.0-r1.ebuild
+++ b/sys-process/atop/atop-2.9.0-r1.ebuild
@@ -49,6 +49,14 @@ src_prepare() {
if use modules ; then
cd "${WORKDIR}"/${NETATOP_P} || die
eapply "${FILESDIR}"/${PN}-2.9.0-netatop-makefile.patch
+
+ sed \
+ -e "s#\`uname -r\`#${KV_FULL}#g" \
+ -e "s#\$(shell uname -r)#${KV_FULL}#g" \
+ -i {.,daemon,module}/Makefile || die
+
+ grep -rq "uname -r" && die "found uname calls"
+
cd "${S}" || die
fi