summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-08 15:22:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-08 15:24:03 +0300
commitd2a560187c928c06c16fb88387957f4c241c0cae (patch)
treeeec823e3453b74fe6e3d9244b0acf601ec086cec /sys-process
parentdev-python/beautifulsoup4: Slotmove 4 → 0 (diff)
downloadgentoo-d2a560187c928c06c16fb88387957f4c241c0cae.tar.gz
gentoo-d2a560187c928c06c16fb88387957f4c241c0cae.tar.bz2
gentoo-d2a560187c928c06c16fb88387957f4c241c0cae.zip
sys-process/iotop-c: initial import (from ::guru)
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.18.ebuild36
-rw-r--r--sys-process/iotop-c/iotop-c-9999.ebuild34
-rw-r--r--sys-process/iotop-c/metadata.xml18
4 files changed, 89 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
new file mode 100644
index 000000000000..4c6717c0a8cb
--- /dev/null
+++ b/sys-process/iotop-c/Manifest
@@ -0,0 +1 @@
+DIST iotop-c-1.18.tar.gz 114838 BLAKE2B 8b3e13d00de4a5cd385a2d441d84bb27cc1d03a27012163b9628285c31176698bf840951e39199abef11b2d3c0413d500d6e7699f32a3b542360a1333307d00e SHA512 f0affbfdb106eb36078e7994860155f52d47878017f47e64d69aa7c04cc29756ca516a6634fd19d6d39c931100b9a0e93e07ca2f4d14c18014dc1c4f477907ea
diff --git a/sys-process/iotop-c/iotop-c-1.18.ebuild b/sys-process/iotop-c/iotop-c-1.18.ebuild
new file mode 100644
index 000000000000..b6d52c5d05fa
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}
diff --git a/sys-process/iotop-c/iotop-c-9999.ebuild b/sys-process/iotop-c/iotop-c-9999.ebuild
new file mode 100644
index 000000000000..b05952298d1d
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/Tomas-M/iotop"
+inherit fcaps git-r3 linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}
diff --git a/sys-process/iotop-c/metadata.xml b/sys-process/iotop-c/metadata.xml
new file mode 100644
index 000000000000..e99460ff502b
--- /dev/null
+++ b/sys-process/iotop-c/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <longdescription lang="en">
+Your Linux server is too slow or load is too high? One of the possible causes of such symptoms may be high IO (input/output) waiting time, which basically means that some of your processes need to read or write to a hard drive while it is too slow and not ready yet, serving data for some other processes.
+
+Common practice is to use iostat -x in order to find out which block device (hard drive) is slow, but such information is not always much helpful. It could help you much more if you knew which process reads or writes the most data from your slow disk, so you could possibly renice it using ionice or even kill it.
+
+IOTop will identify processes, which use high amount of input/output requests on your machine. It is similar to the well known top utility, but instead of showing you what consumes CPU the most, it lists processes by their IO consumption. Inspired by iotop python script from Guillaume Chazarain, but rewritten to C by Vyacheslav Trushkin so it now runs without python at all.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Tomas-M/iotop</remote-id>
+ </upstream>
+</pkgmetadata>