summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-23 13:01:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-23 13:07:51 +0200
commita877d757c0846742b54657fc53ce218e620f23b0 (patch)
tree2fbb2a445327e671a2baa42b7f497d780cc5777b /sys-process
parentdev-cpp/ctemplate: Remove old (diff)
downloadgentoo-a877d757c0846742b54657fc53ce218e620f23b0.tar.gz
gentoo-a877d757c0846742b54657fc53ce218e620f23b0.tar.bz2
gentoo-a877d757c0846742b54657fc53ce218e620f23b0.zip
sys-process/bcron: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/bcron/Manifest1
-rw-r--r--sys-process/bcron/bcron-0.10.ebuild122
2 files changed, 0 insertions, 123 deletions
diff --git a/sys-process/bcron/Manifest b/sys-process/bcron/Manifest
index 8d7c3fd040c1..4adcce6ebb61 100644
--- a/sys-process/bcron/Manifest
+++ b/sys-process/bcron/Manifest
@@ -1,2 +1 @@
-DIST bcron-0.10.tar.gz 68314 BLAKE2B faa7204703af18108675ddb2f2e835cdfcc230f03d80a27b66734110c6354c120f1a2e6357c476b27d72e95935c9bfd805f901521087632cb7e1c26d3b59ba98 SHA512 cfc61651a77bedbaa3e6d9b5e5e8fa070883dfaf1cf314fc47b6114575ad4818f22fb5dd52959a0af077c3f30e2e902fed79feb51dc83adc3b36d20cc587f4a1
DIST bcron-0.11.tar.gz 69950 BLAKE2B 9aaf9e7d8e468a184da97324ccaa6ea557c2d8c3c3557bb90ba9b43b98ac1ddf9bc7d879300394b73c3e5921f9fd7ad8859393076a77a99b9ec3a909e6493a17 SHA512 730e0f4d6fe717ddf89e787d570449f1f7b4b5c44beb2e11b6c88a92177ea02480063f16992f32a13877327b895ca085617dda65de90effd8fb465e578444f05
diff --git a/sys-process/bcron/bcron-0.10.ebuild b/sys-process/bcron/bcron-0.10.ebuild
deleted file mode 100644
index 80624f8a2864..000000000000
--- a/sys-process/bcron/bcron-0.10.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit cron eutils multilib python-any-r1 toolchain-funcs
-
-DESCRIPTION="A new cron system designed with secure operations in mind by Bruce Guenter"
-HOMEPAGE="http://untroubled.org/bcron/"
-SRC_URI="http://untroubled.org/bcron/archive/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=sys-process/cronbase-0.3.2
- virtual/mta
- sys-apps/ucspi-unix
- virtual/daemontools
-"
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- >=dev-libs/bglibs-1.106
-"
-
-CRON_SYSTEM_CRONTAB="yes"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.09-fix-socket-permissions.patch"
- epatch_user
-}
-
-src_configure() {
- echo "/usr/include/bglibs" > conf-bgincs || die
- echo "/usr/$(get_libdir)/bglibs" > conf-bglibs || die
- echo "${D}/usr/bin" > conf-bin || die
- echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
- echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
- echo "${D}/usr/share/man" > conf-man || die
-}
-
-src_install() {
- # DESTDIR is not supported in Makefile
- emake install
-
- #fix permissions of crontab
- fperms o-rwx /usr/bin/bcrontab
- fowners root:cron /usr/bin/bcrontab
-
- doman bcrontab.1 crontab.5 bcron-update.8 bcron-start.8
- doman bcron-spool.8 bcron-sched.8 bcron-exec.8
-
- dodoc ANNOUNCEMENT NEWS README TODO
-
- keepdir /etc/cron.d
-
- keepdir /var/spool/cron/crontabs
- keepdir /var/spool/cron/tmp
-
- for i in crontabs tmp;
- do
- fowners cron:cron /var/spool/cron/$i
- fperms go-rwx /var/spool/cron/$i
- done
-
- dodir /etc/bcron
-
- insinto /etc
- doins "${FILESDIR}"/crontab
-
- insinto /var/lib/supervise/bcron
- doins bcron-sched.run
-
- insinto /var/lib/supervise/bcron/log
- doins bcron-sched-log.run
-
- insinto /var/lib/supervise/bcron-spool
- doins bcron-spool.run
-
- insinto /var/lib/supervise/bcron-update
- doins bcron-update.run
-}
-
-pkg_config() {
- cd "${ROOT}"var/lib/supervise/bcron
- [ -e run ] && cp run bcron-sched.run.`date +%Y%m%d%H%M%S`
- cp bcron-sched.run run
- chmod u+x run
-
- cd "${ROOT}"/var/lib/supervise/bcron/log
- [ -e run ] && cp run bcron-sched-log.run.`date +%Y%m%d%H%M%S`
- cp bcron-sched-log.run run
- chmod u+x run
-
- cd "${ROOT}"/var/lib/supervise/bcron-spool
- [ -e run ] && cp run bcron-spool.run.`date +%Y%m%d%H%M%S`
- cp bcron-spool.run run
- chmod u+x run
-
- cd "${ROOT}"/var/lib/supervise/bcron-update
- [ -e run ] && cp run bcron-update.run.`date +%Y%m%d%H%M%S`
- cp bcron-update.run run
- chmod u+x run
-
- [ ! -e "${ROOT}"/var/spool/cron/trigger ] && mkfifo "${ROOT}"var/spool/cron/trigger
- chown cron:cron /var/spool/cron/trigger
- chmod go-rwx /var/spool/cron/trigger
-}
-
-pkg_postinst() {
- echo
- elog "Run "
- elog "emerge --config =${PF}"
- elog "to create or update your run files (backups are created) in"
- elog " /var/lib/supervise/bcron (bcron daemon) and"
- elog " /var/lib/supervise/bcron-spool (crontab receiver) and"
- elog " /var/lib/supervise/bcron-update (system crontab updater)"
-
- cron_pkg_postinst
-}