summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-19 22:33:35 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2024-11-19 22:33:46 +0100
commita52416fb39087556c76e912eda898bc6057c06e9 (patch)
treec085ebabb056f32c3ec9861a69e48a3f3c46807f /sys-process
parentmedia-video/ffmpeg: fix -Wint-conversion in vulkan (diff)
downloadgentoo-a52416fb39087556c76e912eda898bc6057c06e9.tar.gz
gentoo-a52416fb39087556c76e912eda898bc6057c06e9.tar.bz2
gentoo-a52416fb39087556c76e912eda898bc6057c06e9.zip
sys-process/watchpid: update EAPI 7 -> 8, eautoreconf for fun and profit
Closes: https://bugs.gentoo.org/875119 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/watchpid/files/watchpid-0.1-cflags.patch10
-rw-r--r--sys-process/watchpid/watchpid-0.1-r2.ebuild11
2 files changed, 12 insertions, 9 deletions
diff --git a/sys-process/watchpid/files/watchpid-0.1-cflags.patch b/sys-process/watchpid/files/watchpid-0.1-cflags.patch
index c82e5607f5ab..6c1a731b4603 100644
--- a/sys-process/watchpid/files/watchpid-0.1-cflags.patch
+++ b/sys-process/watchpid/files/watchpid-0.1-cflags.patch
@@ -1,11 +1,9 @@
-https://bugs.gentoo.org/726054
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -64,7 +64,6 @@ VERSION = @VERSION@
-
+diff '--color=auto' -ruN watchpid-0.1.orig/src/Makefile.am watchpid-0.1/src/Makefile.am
+--- watchpid-0.1.orig/src/Makefile.am 2000-07-09 14:28:57.000000000 +0200
++++ watchpid-0.1/src/Makefile.am 2024-11-19 22:31:34.786561111 +0100
+@@ -1,5 +1,4 @@
bin_PROGRAMS = watchpid
watchpid_SOURCES = watchpid.c
-CFLAGS = -Wall -Werror -O3
man_MANS = watchpid.1
EXTRA_DIST = $(man_MANS)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/sys-process/watchpid/watchpid-0.1-r2.ebuild b/sys-process/watchpid/watchpid-0.1-r2.ebuild
index e190ab0d69d9..105a58bae595 100644
--- a/sys-process/watchpid/watchpid-0.1-r2.ebuild
+++ b/sys-process/watchpid/watchpid-0.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit multilib-minimal toolchain-funcs
+inherit multilib-minimal toolchain-funcs autotools
DESCRIPTION="Watches a process for termination"
HOMEPAGE="http://www.codepark.org/"
@@ -17,6 +17,11 @@ PATCHES=(
"${FILESDIR}"/${P}-cflags.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
multilib_src_configure() {
tc-export CC
ECONF_SOURCE="${S}" econf