summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-11-04 15:04:36 -0500
committerRichard Freeman <rich0@gentoo.org>2020-11-04 15:04:53 -0500
commit6b2aaadd3c6dbf050ce126a88dcdee96f6dcf6bd (patch)
tree502e0702156eeb4e35907c3b5626a211fd548658 /sys-process
parentprofiles/targets/desktop/gnome: Enable gles2 on libsdl2 (diff)
downloadgentoo-6b2aaadd3c6dbf050ce126a88dcdee96f6dcf6bd.tar.gz
gentoo-6b2aaadd3c6dbf050ce126a88dcdee96f6dcf6bd.tar.bz2
gentoo-6b2aaadd3c6dbf050ce126a88dcdee96f6dcf6bd.zip
sys-process/systemd-cron: bump, make run-parts optional
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/metadata.xml1
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.5.15.ebuild86
3 files changed, 88 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index b8b1e37e82cc..70c9c67afe38 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1 +1,2 @@
DIST systemd-cron-1.5.14.tar.gz 31634 BLAKE2B 59394128145dbd04a2b1bb10a6ac8821a97a465e3c0d43f3ca8fdfe60db273352d46b1200c966adaf772272835269c5c553b040cb0e0340ec56340181c9b7245 SHA512 772a4f8181a0f8039a8138fdc43bfe0f2bd89222fe19fa971727be265036f86435334d6230e116440f6969425fc6d59dc26e9cf230c00d030ea5d62ba351713c
+DIST systemd-cron-1.5.15.tar.gz 32334 BLAKE2B 7802f442a4ef3d4789f4ea0d534d5c52519313873fa53a43f036e9ffeb36eeec420ff9a5a952b4b7f2f57bfcaf733432e067483dd4984be60c12853ae83a1f9c SHA512 b1c79275b88cba63b69112085d93ba52ba4a2966bdcdc722bdcd69c0270fd02bab96b8045d9ab79781b8f54a79a2ece942d97a6faa7d0cb50c31a13364b7179d
diff --git a/sys-process/systemd-cron/metadata.xml b/sys-process/systemd-cron/metadata.xml
index a2e9865130b7..6386b9371135 100644
--- a/sys-process/systemd-cron/metadata.xml
+++ b/sys-process/systemd-cron/metadata.xml
@@ -8,6 +8,7 @@
<flag name="cron-boot">Include support for the boot timer.</flag>
<flag name="etc-crontab-systemd">Use dedicated /etc/crontab-systemd instead of parsing /etc/crontab</flag>
<flag name="minutely">Support /etc/cron.minutely</flag>
+ <flag name="runparts">Use traditional run-parts instead of creating jobs for each cron.* entry</flag>
<flag name="yearly">Support /etc/cron.yearly</flag>
<flag name="setgid">Compile setgid C helper for crontab. Needs GCC or Clang.</flag>
</use>
diff --git a/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild b/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild
new file mode 100644
index 000000000000..d26a7c23352f
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-1.5.15.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit python-single-r1 systemd
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-apps/systemd-217
+ sys-apps/debianutils
+ !sys-process/cronie[anacron]
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ ${PYTHON_DEPS}
+ sys-process/cronbase"
+
+DEPEND="sys-process/cronbase
+ test? ( sys-apps/man-db dev-python/pyflakes )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ python_fix_shebang --force "${S}/src/bin"
+
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ sed -i \
+ -e 's!/crontab$!/crontab-systemd!' \
+ -e 's!/crontab\(\.[15]\)$!/crontab-systemd\1!' \
+ -e 's/pyflakes3/pyflakes/' \
+ -- "${S}/Makefile.in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.py" || die
+ fi
+
+ eapply_user
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --confdir="${EPREFIX}/etc" \
+ --runparts="${EPREFIX}/bin/run-parts" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ --generatordir="$(systemd_get_systemgeneratordir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable runparts) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) \
+ $(my_use_enable setgid) \
+ --enable-persistent=yes
+}
+
+pkg_postinst() {
+ elog "This package now supports USE=runparts which is enabled by default."
+ elog "This enables the traditional run-parts behavior."
+ elog "If you disable this flag you will get the new behavior of having"
+ elog "multiple jobs for each cron.* entry run in parallel with"
+ elog "separate services/logs/etc."
+}