summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-26 02:51:16 -0400
committerSam James <sam@gentoo.org>2024-05-27 00:11:04 +0100
commit58c1209445f2a301076c966ffe14972eaaaa1438 (patch)
tree0b04877928275fff734c0e392d8c9c0996d66722 /sys-process
parentdev-java/gradle-bin: Stabilize 8.7 amd64, #932767 (diff)
downloadgentoo-58c1209445f2a301076c966ffe14972eaaaa1438.tar.gz
gentoo-58c1209445f2a301076c966ffe14972eaaaa1438.tar.bz2
gentoo-58c1209445f2a301076c966ffe14972eaaaa1438.zip
sys-process/audit: add whitelist for false positive configure implicit decls
Only fails on musl, but does so consistently regardless of -Werror=*. Closes: https://bugs.gentoo.org/898828 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-3.1.1.ebuild8
-rw-r--r--sys-process/audit/audit-3.1.2.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-process/audit/audit-3.1.1.ebuild b/sys-process/audit/audit-3.1.1.ebuild
index ab8e362008db..ffb298d10bcd 100644
--- a/sys-process/audit/audit-3.1.1.ebuild
+++ b/sys-process/audit/audit-3.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -45,6 +45,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.0.8-musl-malloc.patch
)
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # missing on musl. Uses handrolled AC_LINK_IFELSE but fails at link time
+ # for older compilers regardless. bug #898828
+ strndupa
+)
+
src_prepare() {
# audisp-remote moved in multilib_src_install_all
sed -i \
diff --git a/sys-process/audit/audit-3.1.2.ebuild b/sys-process/audit/audit-3.1.2.ebuild
index d2b9730673da..c599682bae4c 100644
--- a/sys-process/audit/audit-3.1.2.ebuild
+++ b/sys-process/audit/audit-3.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -42,6 +42,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.0.8-musl-malloc.patch
)
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # missing on musl. Uses handrolled AC_LINK_IFELSE but fails at link time
+ # for older compilers regardless. bug #898828
+ strndupa
+)
+
src_prepare() {
# audisp-remote moved in multilib_src_install_all
sed -i \