summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-15 23:08:56 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-01-16 19:48:37 -0800
commit23a296b7fb82ae5b8278187d8e3143f073587285 (patch)
tree618d36af04021e52fede1ddb6ad7685c9b7ffe31 /sys-process
parentnet-misc/r8152: Stabilize 2.16.3 amd64, #891015 (diff)
downloadgentoo-23a296b7fb82ae5b8278187d8e3143f073587285.tar.gz
gentoo-23a296b7fb82ae5b8278187d8e3143f073587285.tar.bz2
gentoo-23a296b7fb82ae5b8278187d8e3143f073587285.zip
sys-process/numad: revbump 0.5_p20180531, add more patches
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numad/files/numad-0.5-fix-build-for-no-NR-migrate-pages.patch38
-rw-r--r--sys-process/numad/numad-0.5_p20180531-r1.ebuild (renamed from sys-process/numad/numad-0.5_p20180531.ebuild)3
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-process/numad/files/numad-0.5-fix-build-for-no-NR-migrate-pages.patch b/sys-process/numad/files/numad-0.5-fix-build-for-no-NR-migrate-pages.patch
new file mode 100644
index 000000000000..9f6c5b9caa0b
--- /dev/null
+++ b/sys-process/numad/files/numad-0.5-fix-build-for-no-NR-migrate-pages.patch
@@ -0,0 +1,38 @@
+From c24212bd2dfcfc7074500f07f87790062d9b8acb Mon Sep 17 00:00:00 2001
+From: Kamal Mostafa <kamal@canonical.com>
+Date: Tue, 1 Sep 2015 08:43:22 -0700
+Subject: fix build for platforms with no __NR_migrate_pages syscall
+Reviewed-by: Jeremías Casteglione <debian@jrms.com.ar>
+Reviewed-by: Colin King <colin.king@canonical.com>
+
+---
+ numad.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/numad.c b/numad.c
+index 4c85486..09c5c29 100644
+--- a/numad.c
++++ b/numad.c
+@@ -1022,6 +1022,8 @@ int bind_process_and_migrate_memory(process_data_p p) {
+ free(namelist[namelist_ix]);
+ }
+ free(namelist);
++
++#if defined(__NR_migrate_pages)
+ // Now move the memory to the target nodes....
+ static unsigned long *dest_mask;
+ static unsigned long *from_mask;
+@@ -1083,6 +1085,10 @@ int bind_process_and_migrate_memory(process_data_p p) {
+ p->process_MBs[max_from_node_id] = 0;
+ prev_from_node_id = max_from_node_id;
+ }
++#else // __NR_migrate_pages is not defined
++ numad_log(LOG_DEBUG, "Cannot move memory for PID %d: migrate_pages() system call not supported.\n", p->pid);
++#endif
++
+ // Check pid still active
+ snprintf(fname, FNAME_SIZE, "/proc/%d", p->pid);
+ if (access(fname, F_OK) < 0) {
+--
+1.9.1
+
diff --git a/sys-process/numad/numad-0.5_p20180531.ebuild b/sys-process/numad/numad-0.5_p20180531-r1.ebuild
index a778299f0ae4..229cae6f6556 100644
--- a/sys-process/numad/numad-0.5_p20180531.ebuild
+++ b/sys-process/numad/numad-0.5_p20180531-r1.ebuild
@@ -28,6 +28,9 @@ CONFIG_CHECK="~NUMA ~CPUSETS"
PATCHES=(
# https://pagure.io/numad/pull-request/3
"${FILESDIR}/${PN}-0.5-fix-sparse-node-ids.patch"
+
+ # from debian/ubuntu: https://sources.debian.org/patches/numad
+ "${FILESDIR}/${PN}-0.5-fix-build-for-no-NR-migrate-pages.patch"
)
src_configure() {