summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-01 22:46:43 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-19 17:12:32 -0800
commitfe28d1908e27e8bc4f7e01d673c4bfc7149f855b (patch)
treee32a2bdf6d04690fe1c53f62c118b110f9be3b08 /sys-process/numad
parentmedia-libs/openjpeg: check against known architecture specific failures (diff)
downloadgentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.tar.gz
gentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.tar.bz2
gentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.zip
sys-process/numad: add service files
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-process/numad')
-rw-r--r--sys-process/numad/files/numad.confd6
-rwxr-xr-xsys-process/numad/files/numad.initd14
-rw-r--r--sys-process/numad/files/numad.logrotated5
-rw-r--r--sys-process/numad/numad-9999.ebuild22
4 files changed, 42 insertions, 5 deletions
diff --git a/sys-process/numad/files/numad.confd b/sys-process/numad/files/numad.confd
new file mode 100644
index 000000000000..8767c1102c5a
--- /dev/null
+++ b/sys-process/numad/files/numad.confd
@@ -0,0 +1,6 @@
+# /etc/conf.d/numad: config file for /etc/init.d/numad
+#
+# Options to pass to the numad daemon.
+# See the numad(8) man page for more info.
+
+#NUMAD_OPTS="-v"
diff --git a/sys-process/numad/files/numad.initd b/sys-process/numad/files/numad.initd
new file mode 100755
index 000000000000..afeee8921249
--- /dev/null
+++ b/sys-process/numad/files/numad.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="NUMA daemon that manages application locality"
+
+depend() {
+ need localmount
+ use logger
+}
+
+command="/usr/bin/numad"
+command_args="${NUMAD_OPTS}"
+pidfile="/run/${RC_SVCNAME}.pid"
diff --git a/sys-process/numad/files/numad.logrotated b/sys-process/numad/files/numad.logrotated
new file mode 100644
index 000000000000..bf17dc3335c7
--- /dev/null
+++ b/sys-process/numad/files/numad.logrotated
@@ -0,0 +1,5 @@
+/var/log/numad.log {
+ copytruncate
+ missingok
+ notifempty
+}
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index d292669c500f..9b2cc2d66a7b 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit linux-info toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
inherit git-r3
else
- SRC_URI=""
- KEYWORDS="~amd64 ~x86 -arm -s390"
+ EGIT_COMMIT=""
+ SRC_URI="mirror://gentoo/numad-0.5-${EGIT_COMMIT:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm ~arm64 -s390 ~x86"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT:0:7}"
fi
DESCRIPTION="The NUMA daemon that manages application locality"
@@ -33,4 +35,14 @@ src_compile() {
src_install() {
emake prefix="${ED}/usr" install
+
+ newinitd "${FILESDIR}/numad.initd" numad
+ newconfd "${FILESDIR}/numad.confd" numad
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/numad.logrotated" numad
+
+ insinto /etc
+ doins numad.conf
+ systemd_dounit numad.service
}