summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-03 03:14:22 +0100
committerSam James <sam@gentoo.org>2023-06-10 11:24:02 +0100
commitdd7e0c59bbebb6948aa7acb3b778630d1740847d (patch)
tree7f484c674e707270b76adc12dd92a46c5099e067 /sys-process/lsof
parentsys-process/lsof: drop dead prefix targets (diff)
downloadgentoo-dd7e0c59bbebb6948aa7acb3b778630d1740847d.tar.gz
gentoo-dd7e0c59bbebb6948aa7acb3b778630d1740847d.tar.bz2
gentoo-dd7e0c59bbebb6948aa7acb3b778630d1740847d.zip
sys-process/lsof: drop 4.96.3, 4.96.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/lsof')
-rw-r--r--sys-process/lsof/Manifest2
-rw-r--r--sys-process/lsof/files/lsof-4.85-cross.patch37
-rw-r--r--sys-process/lsof/lsof-4.96.3.ebuild112
-rw-r--r--sys-process/lsof/lsof-4.96.4.ebuild111
4 files changed, 0 insertions, 262 deletions
diff --git a/sys-process/lsof/Manifest b/sys-process/lsof/Manifest
index 448c9e9aa29f..7767d56a6339 100644
--- a/sys-process/lsof/Manifest
+++ b/sys-process/lsof/Manifest
@@ -1,3 +1 @@
-DIST lsof-4.96.3.tar.gz 1342843 BLAKE2B 79e276d0db5138c356cc8bfa32e6f991ce8860644eb5d02f49ba04ce08076232f0fb8b10e143ee135205de5c64bd053d7bf021e48d666b65ffc01c0a47b76116 SHA512 ad17a73590ffb154a13b8b5de8ada738ce343fcc833012b2a5e9b3bda587785b09ae8bf090a99fba8e84b788c2a6d61eaa7359f939bfa68d2423e604801e2a98
-DIST lsof-4.96.4.tar.gz 1342514 BLAKE2B c420e2f928ffa8148a62298ba7176f860b15f9e78f4c2dc299162614a1d9b94a85c42ee93ef5e92b8a99f1c67e496cf2c848874b844c22c287aab53bfe211c58 SHA512 06f8005e1eb72324c1fd603d8b8287a61ad6fdec182e9da833991a8915aaa69c416af1564d3b1087cb08b3504ef9b15cdffec7051605e89d945d6750ec8da985
DIST lsof-4.98.0.tar.gz 734232 BLAKE2B 2f4ba4d179e8061e5bcff7dda4a0981616530bd5577fc73904e2699e6e982efee9e4270d3f2d3c68751d73cb98bfed0fd49d4c6bd967d15b4e06dcb72494d024 SHA512 6fde12497ce9cbba698be624b45e8392d551626c3e46b50ec23e661b322438ef7162dbac0d06829d56f074c7d934fa1ca98aa50ee1487125c93bebfe8eb2a2e8
diff --git a/sys-process/lsof/files/lsof-4.85-cross.patch b/sys-process/lsof/files/lsof-4.85-cross.patch
deleted file mode 100644
index c2c73ccb563f..000000000000
--- a/sys-process/lsof/files/lsof-4.85-cross.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-let the preprocessor work its magic rather than executing the code
-
-https://bugs.gentoo.org/432120
-
-make sure to use -P here
-
-https://bugs.gentoo.org/546636
-
---- a/Configure
-+++ b/Configure
-@@ -2730,20 +2730,17 @@ LOCKF_OWNER4
- rm -f ${LSOF_TMPC}.*
- cat > $LSOF_TMPC.c << .LSOF_END_HERE_DOC1
- #include <features.h>
--main() {
-+#undef XXX
- #if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
--printf("-DGLIBCV=%d\n",__GLIBC__*100+__GLIBC_MINOR__);
-+XXX: __GLIBC__ * 100 + __GLIBC_MINOR__
- #elif defined(__GLIBC__)
--printf("-DGLIBCV=%d00\n",__GLIBC__);
--#else
--printf("\n");
-+XXX: __GLIBC__ * 100
- #endif
--return(0); }
- .LSOF_END_HERE_DOC1
-- $LINUX_CONF_CC ${LSOF_TMPC}.c -I$LSOF_INCLUDE -o ${LSOF_TMPC}.x > /dev/null 2>&1
-+ $LINUX_CONF_CC ${LSOF_TMPC}.c -E -P -I$LSOF_INCLUDE 2>/dev/null | sed -n '/^XXX:/s|.*:||p' > ${LSOF_TMPC}.x
-- if test -x ${LSOF_TMPC}.x # {
-+ if test -s ${LSOF_TMPC}.x # {
- then
-- LINUX_CLIB=`${LSOF_TMPC}.x`
-+ LINUX_CLIB="-DGLIBCV=$(( `cat ${LSOF_TMPC}.x` ))"
- LSOF_TMP=$?
- else
- LINUX_CLIB=""
diff --git a/sys-process/lsof/lsof-4.96.3.ebuild b/sys-process/lsof/lsof-4.96.3.ebuild
deleted file mode 100644
index aa2ed67f1fc4..000000000000
--- a/sys-process/lsof/lsof-4.96.3.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P="${P/-/_}"
-DESCRIPTION="Lists open files for running Unix processes"
-HOMEPAGE="https://github.com/lsof-org/lsof"
-SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="lsof"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples ipv6 rpc selinux"
-
-RDEPEND="rpc? ( net-libs/libtirpc )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}"
-BDEPEND="sys-apps/groff
- rpc? ( virtual/pkgconfig )"
-
-# Needs fixing first
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.85-cross.patch # bug #432120
-)
-
-src_prepare() {
- default
-
- # Fix POSIX compliance with `echo`
- sed -i \
- -e 's:echo -n:printf:' \
- AFSConfig Configure Customize Inventory tests/CkTestDB || die
- # Convert `test -r header.h` into a compile test.
- # Make sure we convert `test ... -a ...` into two `test` commands
- # so we can then convert both over into a compile test. #601432
- sed -i -E \
- -e '/if test .* -a /s: -a : \&\& test :g' \
- -e '/test -r/s:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:g' \
- -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
- Configure || die
-
- # "create" man-page (bug #689462)
- # inspired by shipped "makeman" ksh script
- soelim < Lsof.8 > lsof.8 || die
-}
-
-target() {
- case ${CHOST} in
- *-darwin*) echo darwin ;;
- *-solaris*) echo solaris ;;
- *) echo linux ;;
- esac
-}
-
-src_configure() {
- append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
- append-cppflags $(usex ipv6 -{D,U}HASIPv6)
-
- [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # make sys/proc_info.h available in ${T} because of LSOF_INCLUDE
- # dummy location -- Darwin needs this for a Configure check to
- # succeed
- if [[ -e /usr/include/sys/proc_info.h ]] ; then
- mkdir -p "${T}"/sys || die
- ( cd "${T}"/sys && ln -s /usr/include/sys/proc_info.h ) || die
- fi
- fi
-
- export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
- $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
-
- # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
- # around in it and mix /usr/include paths with cross-compile/etc.
- touch .neverInv
- LINUX_HASSELINUX=$(usex selinux y n) \
- LSOF_INCLUDE=${T} \
- LSOF_CC=$(tc-getCC) \
- LSOF_AR="$(tc-getAR) rc" \
- LSOF_RANLIB=$(tc-getRANLIB) \
- LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
- ./Configure -n $(target) || die
-}
-
-src_compile() {
- emake DEBUG="" all
-}
-
-src_install() {
- dobin lsof
-
- if use examples ; then
- insinto /usr/share/lsof/scripts
- doins scripts/*
- fi
-
- doman lsof.8
- dodoc 00*
-}
-
-pkg_postinst() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- einfo "Note: to use lsof on Solaris you need read permissions on"
- einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
- fi
-}
diff --git a/sys-process/lsof/lsof-4.96.4.ebuild b/sys-process/lsof/lsof-4.96.4.ebuild
deleted file mode 100644
index 83c780162e1a..000000000000
--- a/sys-process/lsof/lsof-4.96.4.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P="${P/-/_}"
-DESCRIPTION="Lists open files for running Unix processes"
-HOMEPAGE="https://github.com/lsof-org/lsof"
-SRC_URI="https://github.com/lsof-org/lsof/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="lsof"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="examples rpc selinux"
-
-RDEPEND="rpc? ( net-libs/libtirpc )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}"
-BDEPEND="sys-apps/groff
- rpc? ( virtual/pkgconfig )"
-
-# Needs fixing first
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.85-cross.patch # bug #432120
-)
-
-src_prepare() {
- default
-
- # Fix POSIX compliance with `echo`
- sed -i \
- -e 's:echo -n:printf:' \
- AFSConfig Configure Customize Inventory tests/CkTestDB || die
- # Convert `test -r header.h` into a compile test.
- # Make sure we convert `test ... -a ...` into two `test` commands
- # so we can then convert both over into a compile test. #601432
- sed -i -E \
- -e '/if test .* -a /s: -a : \&\& test :g' \
- -e '/test -r/s:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:g' \
- -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
- Configure || die
-
- # "create" man-page (bug #689462)
- # inspired by shipped "makeman" ksh script
- soelim < Lsof.8 > lsof.8 || die
-}
-
-target() {
- case ${CHOST} in
- *-darwin*) echo darwin ;;
- *-solaris*) echo solaris ;;
- *) echo linux ;;
- esac
-}
-
-src_configure() {
- append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
-
- [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # make sys/proc_info.h available in ${T} because of LSOF_INCLUDE
- # dummy location -- Darwin needs this for a Configure check to
- # succeed
- if [[ -e /usr/include/sys/proc_info.h ]] ; then
- mkdir -p "${T}"/sys || die
- ( cd "${T}"/sys && ln -s /usr/include/sys/proc_info.h ) || die
- fi
- fi
-
- export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
- $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
-
- # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
- # around in it and mix /usr/include paths with cross-compile/etc.
- touch .neverInv
- LINUX_HASSELINUX=$(usex selinux y n) \
- LSOF_INCLUDE=${T} \
- LSOF_CC=$(tc-getCC) \
- LSOF_AR="$(tc-getAR) rc" \
- LSOF_RANLIB=$(tc-getRANLIB) \
- LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
- ./Configure -n $(target) || die
-}
-
-src_compile() {
- emake DEBUG="" all
-}
-
-src_install() {
- dobin lsof
-
- if use examples ; then
- insinto /usr/share/lsof/scripts
- doins scripts/*
- fi
-
- doman lsof.8
- dodoc 00*
-}
-
-pkg_postinst() {
- if [[ ${CHOST} == *-solaris* ]] ; then
- einfo "Note: to use lsof on Solaris you need read permissions on"
- einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
- fi
-}