summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/htop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/Manifest2
-rw-r--r--sys-process/htop/files/htop-1.0.2-out-of-src.patch30
-rw-r--r--sys-process/htop/files/htop-1.0.2-process.patch13
-rw-r--r--sys-process/htop/files/htop-1.0.2-tinfo.patch58
-rw-r--r--sys-process/htop/files/htop-1.0.3-tinfo.patch62
-rw-r--r--sys-process/htop/htop-1.0.2-r2.ebuild81
-rw-r--r--sys-process/htop/htop-1.0.2.ebuild58
-rw-r--r--sys-process/htop/htop-1.0.3.ebuild83
-rw-r--r--sys-process/htop/metadata.xml18
9 files changed, 405 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
new file mode 100644
index 000000000000..ce3f8d98bd55
--- /dev/null
+++ b/sys-process/htop/Manifest
@@ -0,0 +1,2 @@
+DIST htop-1.0.2.tar.gz 388499 SHA256 ee60657b044ece0df096c053060df7abf3cce3a568ab34d260049e6a37ccd8a1 SHA512 50ae0e8ace862520c01a707b3cf9a19591dc1081f6fc38c7fdccc81e36dd94b3cbe9db00cbb90f782c22d9b73f22526e24d04fad8368c6f2a7de0c58f9d92191 WHIRLPOOL 2766cfe1ea9c98d23c375e5a1c293c6d573d33cf7132e9aaa6ad0335a5f62976a8b8a8da6ede2f03bbadb31ac62e9d7ba5b35138a262dda73eb033afdf27b570
+DIST htop-1.0.3.tar.gz 399306 SHA256 055c57927f75847fdc222b5258b079a9542811a9dcf5421c615c7e17f55d1829 SHA512 4c5c784b093bcad06eb2e8d8bb215e14f6e838a3d47d8da8402344c270c1724f85d0bcde2899571ba5d0e5a02274a0c3390a76fed61785b2604b51351f08f232 WHIRLPOOL 14b8879210025aff9a1e098314a1b35d2bb6fcfaab42b95670e3726c61d471b1618486e6fc3dbbc97043e85f9a22196d97e676f3b2dd98250326be8527bdebbe
diff --git a/sys-process/htop/files/htop-1.0.2-out-of-src.patch b/sys-process/htop/files/htop-1.0.2-out-of-src.patch
new file mode 100644
index 000000000000..d67abe7f4116
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.2-out-of-src.patch
@@ -0,0 +1,30 @@
+ Makefile.am | 2 +-
+ scripts/MakeHeader.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 05a72e7..dd28a87 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -43,7 +43,7 @@ debug:
+ $(MAKE) all CFLAGS="" AM_CPPFLAGS="-ggdb -DDEBUG"
+
+ .c.h:
+- scripts/MakeHeader.py $<
++ $(top_srcdir)/scripts/MakeHeader.py $<
+
+ cppcheck:
+ cppcheck -q -v . --enable=all -DHAVE_CGROUP -DHAVE_OPENVZ -DHAVE_TASKSTATS
+diff --git a/scripts/MakeHeader.py b/scripts/MakeHeader.py
+index 55eeed4..46af921 100755
+--- a/scripts/MakeHeader.py
++++ b/scripts/MakeHeader.py
+@@ -11,7 +11,7 @@ state = ANY
+ static = 0
+
+ file = open(sys.argv[1])
+-name = sys.argv[1][:-2]
++name = os.path.basename(sys.argv[1][:-2])
+
+ out = open(name + ".h", "w")
+ class writer:
diff --git a/sys-process/htop/files/htop-1.0.2-process.patch b/sys-process/htop/files/htop-1.0.2-process.patch
new file mode 100644
index 000000000000..b949e262d35b
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.2-process.patch
@@ -0,0 +1,13 @@
+Index: Process.c
+===================================================================
+--- Process.c (revision 302)
++++ Process.c (working copy)
+@@ -371,7 +371,7 @@
+ }
+
+ static void Process_writeField(Process* this, RichString* str, ProcessField field) {
+- char buffer[128]; buffer[127] = '\0';
++ char buffer[256]; buffer[255] = '\0';
+ int attr = CRT_colors[DEFAULT_COLOR];
+ int baseattr = CRT_colors[PROCESS_BASENAME];
+ int n = sizeof(buffer) - 1;
diff --git a/sys-process/htop/files/htop-1.0.2-tinfo.patch b/sys-process/htop/files/htop-1.0.2-tinfo.patch
new file mode 100644
index 000000000000..4e13459f39c2
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.2-tinfo.patch
@@ -0,0 +1,58 @@
+ Makefile.am | 2 ++
+ configure.ac | 20 ++++++++++++--------
+ 2 files changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 05a72e7..7908937 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,6 +36,8 @@ SUFFIXES = .h
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h
+
++htop_LDADD = $(NCURSES_LIBS)
++
+ profile:
+ $(MAKE) all CFLAGS="" AM_CPPFLAGS="-pg -O2"
+
+diff --git a/configure.ac b/configure.ac
+index ff6901b..6226d90 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,6 +20,7 @@
+ AC_DISABLE_SHARED
+ AC_ENABLE_STATIC
+ AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+ AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
+@@ -89,16 +89,20 @@ fi
+
+ AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
+ if test "x$enable_unicode" = xyes; then
+- AC_CHECK_LIB([ncursesw], [refresh], [], [
+- missing_libraries="$missing_libraries libncursesw"
+- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw],[
++ AC_CHECK_LIB([ncursesw], [refresh], [], [
++ missing_libraries="$missing_libraries libncursesw"
++ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ ])
++ AC_CHECK_HEADERS([ncursesw/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ ])
+- AC_CHECK_HEADERS([ncursesw/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])
+ else
+- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
+- AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ PKG_CHECK_MODULES([NCURSES], [ncurses],[
++ AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
++ AC_CHECK_HEADERS([curses.h],[:],[missing_headers="$missing_headers $ac_header"])
++ ])
+ fi
+
+ if test ! -z "$missing_libraries"; then
diff --git a/sys-process/htop/files/htop-1.0.3-tinfo.patch b/sys-process/htop/files/htop-1.0.3-tinfo.patch
new file mode 100644
index 000000000000..62a887baf376
--- /dev/null
+++ b/sys-process/htop/files/htop-1.0.3-tinfo.patch
@@ -0,0 +1,62 @@
+diff --git a/Makefile.am b/Makefile.am
+index 820e2e5..85f49e9 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -36,6 +36,8 @@ SUFFIXES = .h
+ BUILT_SOURCES = $(myhtopheaders)
+ htop_SOURCES = $(myhtopheaders) $(myhtopsources) config.h
+
++htop_LDADD = $(NCURSES_LIBS)
++
+ profile:
+ $(MAKE) all CFLAGS="-pg" AM_CPPFLAGS="-pg -O2 -DNDEBUG"
+
+diff --git a/configure.ac b/configure.ac
+index 2b934e8..3593885 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -20,6 +20,7 @@ AM_PROG_CC_C_O
+ AC_DISABLE_SHARED
+ AC_ENABLE_STATIC
+ AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
+
+ # Checks for libraries.
+ AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
+@@ -89,20 +90,24 @@ fi
+
+ AC_ARG_ENABLE(unicode, [AC_HELP_STRING([--enable-unicode], [enable Unicode support])], ,enable_unicode="yes")
+ if test "x$enable_unicode" = xyes; then
+- AC_CHECK_LIB([ncursesw], [refresh], [], [
+- missing_libraries="$missing_libraries libncursesw"
+- AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ PKG_CHECK_MODULES([NCURSES], [ncursesw],[
++ AC_CHECK_LIB([ncursesw], [refresh], [], [
++ missing_libraries="$missing_libraries libncursesw"
++ AC_MSG_ERROR([You may want to use --disable-unicode or install libncursesw.])
++ ])
++ AC_CHECK_HEADERS([ncursesw/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
+ ])
+- AC_CHECK_HEADERS([ncursesw/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
+ else
+- AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
+- AC_CHECK_HEADERS([curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/curses.h],[:],
+- [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
+- [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++ PKG_CHECK_MODULES([NCURSES], [ncurses],[
++ AC_CHECK_LIB([ncurses], [refresh], [], [missing_libraries="$missing_libraries libncurses"])
++ AC_CHECK_HEADERS([curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/curses.h],[:],
++ [AC_CHECK_HEADERS([ncurses/ncurses.h],[:],
++ [AC_CHECK_HEADERS([ncurses.h],[:],[missing_headers="$missing_headers $ac_header"])])])])
++ ])
+ fi
+
+ if test ! -z "$missing_libraries"; then
diff --git a/sys-process/htop/htop-1.0.2-r2.ebuild b/sys-process/htop/htop-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..3ad83786ea32
--- /dev/null
+++ b/sys-process/htop/htop-1.0.2-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils linux-info python-any-r1
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+# config.h problems
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ echo
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ echo
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-process.patch
+ "${FILESDIR}"/${P}-out-of-src.patch
+)
+
+src_prepare() {
+ rm missing || die
+ sed \
+ -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ -i scripts/MakeHeader.py || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=()
+
+ use kernel_FreeBSD && myeconfargs+=( --with-proc=/compat/linux/proc )
+
+ myeconfargs+=(
+ $(use_enable openvz)
+ $(use_enable kernel_linux cgroup)
+ $(use_enable vserver)
+ $(use_enable unicode)
+ --enable-taskstats
+ )
+ autotools-utils_src_configure
+}
diff --git a/sys-process/htop/htop-1.0.2.ebuild b/sys-process/htop/htop-1.0.2.ebuild
new file mode 100644
index 000000000000..28e1a571d4a8
--- /dev/null
+++ b/sys-process/htop/htop-1.0.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ echo
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ echo
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myconf=''
+
+ use kernel_FreeBSD && myconf="${myconf} --with-proc=/compat/linux/proc"
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats \
+ ${myconf}
+}
diff --git a/sys-process/htop/htop-1.0.3.ebuild b/sys-process/htop/htop-1.0.3.ebuild
new file mode 100644
index 000000000000..a0b4ab8a3891
--- /dev/null
+++ b/sys-process/htop/htop-1.0.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils linux-info python-any-r1
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://hisham.hm/htop/"
+SRC_URI="http://hisham.hm/htop/releases/${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux oom openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+# config.h problems
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=("${FILESDIR}/${P}-tinfo.patch")
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ echo
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ echo
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ rm missing || die
+
+ sed \
+ -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ -i scripts/MakeHeader.py || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ local myeconfargs=()
+
+ use kernel_FreeBSD && myeconfargs+=( --with-proc=/compat/linux/proc )
+
+ myeconfargs+=(
+ $(use_enable openvz)
+ $(use_enable kernel_linux cgroup)
+ $(use_enable vserver)
+ $(use_enable unicode)
+ $(use_enable oom)
+ --enable-taskstats
+ )
+ autotools-utils_src_configure
+}
diff --git a/sys-process/htop/metadata.xml b/sys-process/htop/metadata.xml
new file mode 100644
index 000000000000..1cc6802ab8d2
--- /dev/null
+++ b/sys-process/htop/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ </maintainer>
+ <use>
+ <flag name="oom">Add column to track the OOM-killer score of processes</flag>
+ <flag name="openvz">Enable openvz support</flag>
+ <flag name="vserver">Enable vserver support</flag>
+ </use>
+ <longdescription>
+htop is an interactive process viewer for Linux. It aims to be a 'better top':
+you can scroll the process list vertically and horizontally, and select a
+process to be killed with the arrow keys instead of by typing its process id.
+ </longdescription>
+</pkgmetadata>