summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-power/iasl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-power/iasl/files')
-rw-r--r--sys-power/iasl/files/iasl-20080701-parallelmake.patch47
-rw-r--r--sys-power/iasl/files/iasl-20120816-locale.patch15
-rw-r--r--sys-power/iasl/files/iasl-20140214-locale.patch14
-rw-r--r--sys-power/iasl/files/iasl-20140214-nostrip.patch11
-rw-r--r--sys-power/iasl/files/iasl-20140828-locale.patch17
5 files changed, 104 insertions, 0 deletions
diff --git a/sys-power/iasl/files/iasl-20080701-parallelmake.patch b/sys-power/iasl/files/iasl-20080701-parallelmake.patch
new file mode 100644
index 000000000000..ce51efedbab7
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20080701-parallelmake.patch
@@ -0,0 +1,47 @@
+Index: acpica-unix-20080701.old/compiler/Makefile
+===================================================================
+--- acpica-unix-20080701.old.orig/compiler/Makefile
++++ acpica-unix-20080701.old/compiler/Makefile
+@@ -1,7 +1,7 @@
+
+
+ PROG= iasl
+-SRCS= aslcompilerparse.c aslcompilerlex.c aslanalyze.c aslcodegen.c \
++SRCS= aslcompiler.y.c aslcompilerlex.c aslanalyze.c aslcodegen.c \
+ aslcompile.c aslerror.c aslfiles.c asllength.c \
+ asllisting.c aslload.c asllookup.c aslmain.c aslmap.c aslopcodes.c \
+ asloperands.c aslresource.c aslrestype1.c aslrestype2.c aslstartup.c \
+@@ -89,6 +89,7 @@ SRCS= aslcompilerparse.c aslcompilerlex.
+ ../tables/tbutils.c \
+ ../tables/tbxface.c \
+ ../osunixxf.c
++OBJS = $(patsubst %.c,%.o, $(SRCS))
+
+ NOMAN= YES
+ CFLAGS+= -Wall -O2 -Wstrict-prototypes -D_LINUX -DACPI_ASL_COMPILER -I../include
+@@ -105,17 +106,19 @@ YFLAGS+= -y -pAslCompiler
+ #CFLAGS+= -D_USE_BERKELEY_YACC
+ #.endif
+
+-aslmain : $(patsubst %.c,%.o, $(SRCS))
++aslmain : $(OBJS)
+ $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) \
+ $(LOADLIBES) $(LDLIBS) -o iasl
+
++$(OBJS): aslcompiler.y.h
++
+ CLEANFILES= y.output y.tab.c y.tab.h aslcompiler.y.h \
+- aslcompilerparse.c aslcompilerlex.c iasl
++ aslcompiler.y.c aslcompilerlex.c iasl
++
++aslcompiler.y.h: aslcompiler.y.c
+
+-aslcompilerparse.c: aslcompiler.y
+- ${YACC} ${YFLAGS} aslcompiler.y
+- cp y.tab.c aslcompilerparse.c
+- cp y.tab.h aslcompiler.y.h
++aslcompiler.y.c: aslcompiler.y
++ ${YACC} ${YFLAGS} aslcompiler.y -o aslcompiler.y.c
+
+ aslcompilerlex.c: aslcompiler.l
+ ${LEX} ${LFLAGS} -PAslCompiler -oaslcompilerlex.c aslcompiler.l
diff --git a/sys-power/iasl/files/iasl-20120816-locale.patch b/sys-power/iasl/files/iasl-20120816-locale.patch
new file mode 100644
index 000000000000..425513342105
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20120816-locale.patch
@@ -0,0 +1,15 @@
+diff -Nuar acpica-unix-20120816.orig/generate/unix/Makefile.config acpica-unix-20120816/generate/unix/Makefile.config
+--- acpica-unix-20120816.orig/generate/unix/Makefile.config 2012-08-16 15:51:15.000000000 +0000
++++ acpica-unix-20120816/generate/unix/Makefile.config 2012-09-07 18:31:41.887229126 +0000
+@@ -161,9 +161,9 @@
+ #YACC= byacc
+ #YFLAGS += -v -d
+ #
+-YACC= bison
++YACC= LC_ALL=C bison
+ YFLAGS += -v -d -y
+
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS += -i -s
+
diff --git a/sys-power/iasl/files/iasl-20140214-locale.patch b/sys-power/iasl/files/iasl-20140214-locale.patch
new file mode 100644
index 000000000000..53a4d7c5efb1
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20140214-locale.patch
@@ -0,0 +1,14 @@
+--- acpica-unix-20140214/generate/unix/Makefile.config
++++ acpica-unix-20140214/generate/unix/Makefile.config
+@@ -211,9 +211,9 @@
+ #YACC= byacc
+ #YFLAGS +=
+ #
+-YACC= bison
++YACC= LC_ALL=C bison
+ YFLAGS += -y
+
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS += -i -s
+
diff --git a/sys-power/iasl/files/iasl-20140214-nostrip.patch b/sys-power/iasl/files/iasl-20140214-nostrip.patch
new file mode 100644
index 000000000000..0bb82df38c3c
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20140214-nostrip.patch
@@ -0,0 +1,11 @@
+--- acpica-unix-20140214/generate/unix/Makefile.config
++++ acpica-unix-20140214/generate/unix/Makefile.config
+@@ -52,7 +52,7 @@
+ INSTALLFLAGS ?= -f
+ else
+ INSTALL = install
+-INSTALLFLAGS ?= -m 555 -s
++INSTALLFLAGS ?= -m 555
+ endif
+
+ INSTALLPROG = \
diff --git a/sys-power/iasl/files/iasl-20140828-locale.patch b/sys-power/iasl/files/iasl-20140828-locale.patch
new file mode 100644
index 000000000000..c8e278f7572a
--- /dev/null
+++ b/sys-power/iasl/files/iasl-20140828-locale.patch
@@ -0,0 +1,17 @@
+--- acpica-unix-20140828/generate/unix/Makefile.config
++++ acpica-unix-20140828/generate/unix/Makefile.config
+@@ -225,12 +225,12 @@
+ #YACC= byacc
+ #YFLAGS +=
+ #
+-YACC= bison
++YACC= LC_ALL=C bison
+ YFLAGS += -y
+
+ MACROPROC= m4
+ MFLAGS= -P -I$(ASL_COMPILER)
+
+-LEX= flex
++LEX= LC_ALL=C flex
+ LFLAGS += -i -s
+