summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-12 20:26:34 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-13 13:11:21 +0200
commitbefe3c626e3f90a16bbeb37ac2770e569c2c5dd9 (patch)
tree00b4555b0f938d26efc58ec84fc23c390bebc4ee /sys-libs
parentsys-libs/llvm-libunwind: Enable Python 3.7 in -9999 (diff)
downloadgentoo-befe3c626e3f90a16bbeb37ac2770e569c2c5dd9.tar.gz
gentoo-befe3c626e3f90a16bbeb37ac2770e569c2c5dd9.tar.bz2
gentoo-befe3c626e3f90a16bbeb37ac2770e569c2c5dd9.zip
sys-libs/llvm-libunwind: Build static libc++* for tests in -9999
Build static libc++ & libc++abi to avoid linking problems against libgcc. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index d4216d8cc894..a5c5c542e433 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -92,8 +92,8 @@ build_libcxxabi() {
local BUILD_DIR=${BUILD_DIR}/libcxxabi
local mycmakeargs=(
-DLIBCXXABI_LIBDIR_SUFFIX=
- -DLIBCXXABI_ENABLE_SHARED=ON
- -DLIBCXXABI_ENABLE_STATIC=OFF
+ -DLIBCXXABI_ENABLE_SHARED=OFF
+ -DLIBCXXABI_ENABLE_STATIC=ONF
-DLIBCXXABI_USE_LLVM_UNWINDER=ON
-DLIBCXXABI_INCLUDE_TESTS=OFF
@@ -111,8 +111,8 @@ build_libcxx() {
local BUILD_DIR=${BUILD_DIR}/libcxx
local mycmakeargs=(
-DLIBCXX_LIBDIR_SUFFIX=
- -DLIBCXX_ENABLE_SHARED=ON
- -DLIBCXX_ENABLE_STATIC=OFF
+ -DLIBCXX_ENABLE_SHARED=OFF
+ -DLIBCXX_ENABLE_STATIC=ON
-DLIBCXX_ENABLE_EXPERIMENTAL_LIBRARY=OFF
-DLIBCXXABI_USE_LLVM_UNWINDER=ON
-DLIBCXX_CXX_ABI=libcxxabi