summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-11 10:26:34 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-11 10:26:45 +0200
commit8fb89559bcdc677a5b4afefbbb459e24577f7d77 (patch)
treebd5bc1c8e3804f7ff98746538e4706e307530bd5 /sys-libs
parentx11-misc/xlockmore: Old (diff)
downloadgentoo-8fb89559bcdc677a5b4afefbbb459e24577f7d77.tar.gz
gentoo-8fb89559bcdc677a5b4afefbbb459e24577f7d77.tar.bz2
gentoo-8fb89559bcdc677a5b4afefbbb459e24577f7d77.zip
sys-libs/libutempter: Bump to version 1.2.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libutempter/Manifest1
-rw-r--r--sys-libs/libutempter/libutempter-1.2.0.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sys-libs/libutempter/Manifest b/sys-libs/libutempter/Manifest
index 4da638713d07..3c0a54caf212 100644
--- a/sys-libs/libutempter/Manifest
+++ b/sys-libs/libutempter/Manifest
@@ -1 +1,2 @@
DIST libutempter-1.1.6.tar.bz2 15705 BLAKE2B 147bf96990913019c35565507eb635ba60ff5ed67134805e9f146f8f70882615ff96d7b2e52b40fb73110905afb87893a72bdec4327d879e5bdc2ec1d39ff9f0 SHA512 6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede
+DIST libutempter-1.2.0.tar.gz 17353 BLAKE2B 35e66a32e70fa59639f9a4fb71ba0e89c88aedac04e389cd29397c935daea66bd9f4f04795c977911f136b121d0445f79c0090a60a0353d04af98fe6b9b9ee09 SHA512 24b9fb59269b48bfee397520907c74746a7a38cf12cc002a8adcdd930460036caea7c72fe47b93badf678dc8306786bf4d87f23ee696a524bfc93722ea1eed23
diff --git a/sys-libs/libutempter/libutempter-1.2.0.ebuild b/sys-libs/libutempter/libutempter-1.2.0.ebuild
new file mode 100644
index 000000000000..271a41f8bde7
--- /dev/null
+++ b/sys-libs/libutempter/libutempter-1.2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info"
+HOMEPAGE="https://altlinux.org/index.php?module=sisyphus&package=libutempter"
+SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs elibc_FreeBSD"
+
+RDEPEND="
+ !sys-apps/utempter
+ acct-group/utmp
+"
+
+src_prepare() {
+ default
+
+ local args=(
+ -e "/^libdir /s:/usr/lib:${EPREFIX}/usr/$(get_libdir):"
+ -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
+ -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
+ -e 's:-Wl,-stats::'
+ -e "/^includedir /s:/usr/include:${EPREFIX}/usr/include:"
+ -e "/^mandir /s:=.*:= ${EPREFIX}/usr/share/man:"
+ )
+ use static-libs || args+=(
+ -e '/^STATICLIB/d'
+ -e '/INSTALL.*STATICLIB/d'
+ )
+ sed -i "${args[@]}" Makefile || die
+}
+
+src_configure() {
+ use elibc_FreeBSD && append-libs -lutil
+ tc-export AR CC
+}
+
+src_compile() {
+ emake LDLIBS="${LIBS}"
+}
+
+src_install() {
+ default
+
+ if ! use prefix ; then
+ fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
+ fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
+ fi
+ dodir /usr/sbin
+ dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
+}
+
+pkg_postinst() {
+ if [[ -f "${EROOT}/var/log/wtmp" ]] ; then
+ chown root:utmp "${EROOT}/var/log/wtmp"
+ chmod 664 "${EROOT}/var/log/wtmp"
+ fi
+
+ if [[ -f "${EROOT}/var/run/utmp" ]] ; then
+ chown root:utmp "${EROOT}/var/run/utmp"
+ chmod 664 "${EROOT}/var/run/utmp"
+ fi
+}