summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-07 18:37:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-07 18:41:27 +0200
commit0848095215b24252944a5091236b8f11ec9bceb2 (patch)
treeb01a9db5e0e91e5cacce9f671f8da48a09651602 /sys-libs
parentsys-devel/lld: Use the new version vars (diff)
downloadgentoo-0848095215b24252944a5091236b8f11ec9bceb2.tar.gz
gentoo-0848095215b24252944a5091236b8f11ec9bceb2.tar.bz2
gentoo-0848095215b24252944a5091236b8f11ec9bceb2.zip
sys-libs/llvm-libunwind: Use the new version vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild7
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild7
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20221006.ebuild7
3 files changed, 9 insertions, 12 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
index 67d11a24dc77..b53a48502232 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.2.9999.ebuild
@@ -20,13 +20,12 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAJOR}
"
BDEPEND="
clang? (
- sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
@@ -46,7 +45,7 @@ python_check_deps() {
}
pkg_setup() {
- llvm_pkg_setup
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
index 67d11a24dc77..b53a48502232 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0.9999.ebuild
@@ -20,13 +20,12 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAJOR}
"
BDEPEND="
clang? (
- sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
@@ -46,7 +45,7 @@ python_check_deps() {
}
pkg_setup() {
- llvm_pkg_setup
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20221006.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20221006.ebuild
index 71139d2b5fda..1d7329494c4c 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20221006.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-16.0.0_pre20221006.ebuild
@@ -20,13 +20,12 @@ RESTRICT="!test? ( test )"
RDEPEND="
!sys-libs/libunwind
"
-LLVM_MAX_SLOT=${PV%%.*}
DEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-devel/llvm:${LLVM_MAJOR}
"
BDEPEND="
clang? (
- sys-devel/clang:${LLVM_MAX_SLOT}
+ sys-devel/clang:${LLVM_MAJOR}
)
!test? (
${PYTHON_DEPS}
@@ -46,7 +45,7 @@ python_check_deps() {
}
pkg_setup() {
- llvm_pkg_setup
+ LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}