summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-07 18:42:56 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-07 19:39:44 +0000
commitd0bf3364d7179e707a55f502c2e760a2daafb5db (patch)
tree1408f627701fece8921b7a3018585a6d54987091 /sys-libs/musl
parentsys-libs/newlib: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only (diff)
downloadgentoo-d0bf3364d7179e707a55f502c2e760a2daafb5db.tar.gz
gentoo-d0bf3364d7179e707a55f502c2e760a2daafb5db.tar.bz2
gentoo-d0bf3364d7179e707a55f502c2e760a2daafb5db.zip
sys-libs/musl: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only
CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only. Convert it to a global USE flag instead. Mechanical ebuild rename done as: $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \ -i $(git grep -l headers-only) 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/musl-1.1.18.ebuild6
-rw-r--r--sys-libs/musl/musl-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/musl/musl-1.1.18.ebuild b/sys-libs/musl/musl-1.1.18.ebuild
index a36df0d0e875..e36e21994580 100644
--- a/sys-libs/musl/musl-1.1.18.ebuild
+++ b/sys-libs/musl/musl-1.1.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,7 +32,7 @@ DESCRIPTION="Light, fast and simple C library focused on standards-conformance a
HOMEPAGE="http://www.musl-libc.org/"
LICENSE="MIT LGPL-2 GPL-2"
SLOT="0"
-IUSE="crosscompile_opts_headers-only"
+IUSE="headers-only"
QA_SONAME="/usr/lib/libc.so"
QA_DT_NEEDED="/usr/lib/libc.so"
@@ -42,7 +42,7 @@ is_crosscompile() {
}
just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
+ use headers-only && is_crosscompile
}
pkg_setup() {
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 9e0e184d6562..991afd750a8f 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -32,7 +32,7 @@ DESCRIPTION="Light, fast and simple C library focused on standards-conformance a
HOMEPAGE="http://www.musl-libc.org/"
LICENSE="MIT LGPL-2 GPL-2"
SLOT="0"
-IUSE="crosscompile_opts_headers-only"
+IUSE="headers-only"
QA_SONAME="/usr/lib/libc.so"
QA_DT_NEEDED="/usr/lib/libc.so"
@@ -42,7 +42,7 @@ is_crosscompile() {
}
just_headers() {
- use crosscompile_opts_headers-only && is_crosscompile
+ use headers-only && is_crosscompile
}
pkg_setup() {