summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-06-13 10:07:36 +0800
committerYixun Lan <dlan@gentoo.org>2016-06-13 10:07:55 +0800
commit17093f1082a727de41cbce525c3011bec9822bd5 (patch)
treec6e6362e2fd3113aa6edbf07bc1c766ac9a013a8 /sys-libs/libunwind
parentsys-kernel/git-sources: Linux patch 4.7_rc3 (diff)
downloadgentoo-17093f1082a727de41cbce525c3011bec9822bd5.tar.gz
gentoo-17093f1082a727de41cbce525c3011bec9822bd5.tar.bz2
gentoo-17093f1082a727de41cbce525c3011bec9822bd5.zip
sys-libs/libunwind: version bump to 1.2_rc1, add arm64 support
Gentoo-Bug: 584720 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sys-libs/libunwind')
-rw-r--r--sys-libs/libunwind/Manifest1
-rw-r--r--sys-libs/libunwind/libunwind-1.2_rc1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index fa690d83e6cf..9896532437fb 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1,3 +1,4 @@
DIST libunwind-0.99.tar.gz 711817 SHA256 56083aae17eab3ccb7a36b95f0430f5a5f258755bf193bb5ca4fd4b918356164 SHA512 26796c546490c3065d04e2143b8a4a7bcc3d3d8fc0c1c8bc1da1ddfb6abc0807d994fe83f008e82ba7cb78525d6fe66800aafa266e931a6aef9813283f904daf WHIRLPOOL 868cf12c71fb1ca64da185e3e804bcddfafd70f8c443c7ca5684f9fa99f1a1943bb75cc4137082a5bd3865a6aeea39c1b2ad68d62db261d14164afded8f0ee3e
DIST libunwind-1.0.1.tar.gz 1028725 SHA256 aa95fd184c0b90d95891c2f3bac2c7df708ff016d2a6ee8b2eabb769f864101f SHA512 e360f0c0abf1e8b153a01cf522237495cecd9b4c689fa55868e60cec86f650e86ceefa283c045fa3d4bd50dc130e75ce7a8ad221c8f938c20a56f106aa3de8c5 WHIRLPOOL 0a2bcfdabb97cb541f7050203db4b658d0b853fdeb504e5917a731547a673e78db9ea0a64ee17ffc137017fc474c7ba44086fdbf2f5f3519993b5bd0048c76b4
DIST libunwind-1.1.tar.gz 1098603 SHA256 9dfe0fcae2a866de9d3942c66995e4b460230446887dbdab302d41a8aee8d09a SHA512 bfe04f2bfac9f9e47c37f0b23ed2f264d8d3d3d6f1392fe9d794ee13cad216b3740979e922e4276fb65c1ccdc836fce48812cb5459ecdd2a89a621036a35d7c1 WHIRLPOOL 1a0e566edf92c0563cb5525203f2718c3454bc0be25ec8079cde8441de08b6d8951db7cbf2f0a02a4a0f1e6c350e74e551a482d9094996daefa216a79bc9d383
+DIST libunwind-1.2-rc1.tar.gz 1172290 SHA256 d222f186b6bc60f49dac5030516ec35a7ed0ccca675551d6cf81008112116abc SHA512 810cdcf9e1e9a33eb286a6527c2d4bfc507313c596df9cdeb46b1c7b7343ac784fec3ed7c6aa135fc25dbf3e2cd8c99d1fa51e265b63614b51fd37bd84000b08 WHIRLPOOL 655c1eb356990aa35429207f54834da79c8aa83a506b0a51f72d1dafb236095a9420c1ca2f29a0dacb93d063bc244ebbddf5e74097e189df11f0ea7ad50b9447
diff --git a/sys-libs/libunwind/libunwind-1.2_rc1.ebuild b/sys-libs/libunwind/libunwind-1.2_rc1.ebuild
new file mode 100644
index 000000000000..e3d819d9c6d0
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.2_rc1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+inherit eutils libtool
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
+SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="7"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug debug-frame doc libatomic lzma static-libs"
+
+RESTRICT="test" #461958 -- re-enable tests with >1.1 again for retesting, this is here for #461394
+
+# We just use the header from libatomic.
+RDEPEND="lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ libatomic? ( dev-libs/libatomic_ops )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+QA_DT_NEEDED_x86_fbsd="usr/lib/libunwind.so.7.0.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # These tests like to fail. bleh.
+ echo 'int main(){return 0;}' > tests/Gtest-dyn1.c
+ echo 'int main(){return 0;}' > tests/Ltest-dyn1.c
+}
+
+src_configure() {
+ # do not $(use_enable) because the configure.in is broken and parses
+ # --disable-debug the same as --enable-debug.
+ # https://savannah.nongnu.org/bugs/index.php?34324
+ # --enable-cxx-exceptions: always enable it, headers provide the interface
+ # and on some archs it is disabled by default causing a mismatch between the
+ # API and the ABI, bug #418253
+ # conservative-checks: validate memory addresses before use; as of 1.0.1,
+ # only x86_64 supports this, yet may be useful for debugging, couple it with
+ # debug useflag.
+ ac_cv_header_atomic_ops_h=$(usex libatomic) \
+ econf \
+ --enable-cxx-exceptions \
+ --enable-coredump \
+ --enable-ptrace \
+ --enable-setjmp \
+ $(use_enable debug-frame) \
+ $(use_enable doc documentation) \
+ $(use_enable lzma minidebuginfo) \
+ $(use_enable static-libs static) \
+ $(use_enable debug conservative_checks) \
+ $(use debug && echo --enable-debug)
+}
+
+src_test() {
+ # Explicitly allow parallel build of tests.
+ # Sandbox causes some tests to freak out.
+ SANDBOX_ON=0 emake check
+}
+
+src_install() {
+ default
+ # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
+ # shared library, so we keep it in any case
+ use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
+}