summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2023-09-17 18:28:11 -0400
committerMike Pagano <mpagano@gentoo.org>2023-09-17 18:28:23 -0400
commitebba010cb4264173d61c3b661b3f18e6be921136 (patch)
tree84dfedaee5ea79a4d75295a0e71a1d956138dfef /sys-kernel
parentapp-misc/gnote: Version bump to 45_rc (diff)
downloadgentoo-ebba010cb4264173d61c3b661b3f18e6be921136.tar.gz
gentoo-ebba010cb4264173d61c3b661b3f18e6be921136.tar.bz2
gentoo-ebba010cb4264173d61c3b661b3f18e6be921136.zip
sys-kernel/git-sources: add 6.6_rc2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.6_rc2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 34bef9e1ecd2..8ab2dbb85e18 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.5.tar.xz 138898084 BLAKE2B 2e641b79a080e8f4ce283bcf6b74e2c6f15a374367f1c4c875c663868dbe801317340824fb3adb46b3a51d3b7e1f67cc4e8144d367621ec43ffba5c4eb8abb39 SHA512 1b59dc5e65d4922c3217a8c8f19022dfd6595ae89747861d825bfeb51a4ae6c85449d05db69635a712bef7b355b80318195665582d8933b1fed6ba582f6ff257
DIST patch-6.6-rc1.patch 39118113 BLAKE2B 8301642b0c12def7ee0e49a23876a3a106b345bb7877d0b9a4fd644dc6af69826bbc50028a93bb6f951b17c5d3be290e8d36a69ca765637a4b689bdb9430a672 SHA512 7d9fe9f89b8ad875ca57ccb1730ae4e853c36ef4e47d31d1d91488461e4a37c49b54b4ca5036c6c9ec7ae63101e56b06a3386a7784ae8173b6fae4a7e87e7977
+DIST patch-6.6-rc2.patch 39377615 BLAKE2B 1a3ec1d61c620a29678140eb7d85ea13e40f4603fae73d77ef6695114a9cf9c65093dfab2ff3c3ca2c8ed9a86a915c60cef8726a088fe0a6af0363c53a1317a4 SHA512 4a7c6ef50493bb8fcacaf662430c3117ba373c739bd14e68d7c218aeae18de1445fea1747cbf948162399ca4227c51679d256a12e5940890ac1ddd6b37b283b8
diff --git a/sys-kernel/git-sources/git-sources-6.6_rc2.ebuild b/sys-kernel/git-sources/git-sources-6.6_rc2.ebuild
new file mode 100644
index 000000000000..5065c9cfd114
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.6_rc2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.5"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}