summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2016-08-20 21:02:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-27 15:56:33 +0200
commitaf1737261a57f4189a42aaa4523491555c7402cb (patch)
treea6e24002b372944561e5050d55ab9b4a43193b7b /sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild
parentnet-print/hplip-plugin: Clean up old. (diff)
downloadgentoo-af1737261a57f4189a42aaa4523491555c7402cb.tar.gz
gentoo-af1737261a57f4189a42aaa4523491555c7402cb.tar.bz2
gentoo-af1737261a57f4189a42aaa4523491555c7402cb.zip
sys-kernel/rt-sources: version bump to {3.14.75_p80,3.18.39_p41,4.1.30_p34,4.4.17_p25,4.6.5_p10}
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2112 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild b/sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild
new file mode 100644
index 000000000000..581fa5914db9
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.1.30_p34.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."