summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-04-23 11:30:26 +0800
committerWANG Xuerui <xen0n@gentoo.org>2022-04-24 09:58:15 +0800
commitb1143c32b2da85400b721fed0d49bbdffe055280 (patch)
tree97e37139d8195c1ccd4369e199caa07d5bbccff4 /sys-kernel/linux-headers/linux-headers-5.17.ebuild
parentprofiles/arch/base: mask sys-libs/glibc[experimental-loong] (diff)
downloadgentoo-b1143c32b2da85400b721fed0d49bbdffe055280.tar.gz
gentoo-b1143c32b2da85400b721fed0d49bbdffe055280.tar.bz2
gentoo-b1143c32b2da85400b721fed0d49bbdffe055280.zip
sys-kernel/linux-headers: add experimental loong patchset
Closes: https://github.com/gentoo/gentoo/pull/25162 Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.17.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.17.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.17.ebuild b/sys-kernel/linux-headers/linux-headers-5.17.ebuild
deleted file mode 100644
index eef1c69bd485..000000000000
--- a/sys-kernel/linux-headers/linux-headers-5.17.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
-inherit kernel-2
-detect_version
-
-PATCH_PV=${PV} # to ease testing new versions against not existing patches
-PATCH_VER="0"
-PATCH_DEV="sam"
-SRC_URI="${KERNEL_URI}
- ${PATCH_VER:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/sys-kernel/linux-headers/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}"
-S="${WORKDIR}/linux-${PV}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="app-arch/xz-utils
- dev-lang/perl"
-
-# bug #816762
-RESTRICT="test"
-
-[[ -n ${PATCH_VER} ]] && PATCHES=( "${WORKDIR}"/${PATCH_PV} )
-
-src_unpack() {
- # avoid kernel-2_src_unpack
- default
-}
-
-src_prepare() {
- # TODO: May need forward porting to newer versions
- use elibc_musl && PATCHES+=(
- "${FILESDIR}"/${PN}-5.10-Use-stddefs.h-instead-of-compiler.h.patch
- "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
- )
-
- # avoid kernel-2_src_prepare
- default
-}
-
-src_test() {
- emake headers_check ${xmakeopts}
-}
-
-src_install() {
- kernel-2_src_install
-
- find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
- # delete empty directories
- find "${ED}" -empty -type d -delete || die
-}