summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-03 19:41:05 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-03 19:42:05 +0200
commitab67f953d2114b604581132459ed7a9e4cbdf4df (patch)
treeeff23da1f5a69f80f0336bb02085010083ce4a62 /sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
parentsys-apps/keyutils: Bump to version 1.6.1 (diff)
downloadgentoo-ab67f953d2114b604581132459ed7a9e4cbdf4df.tar.gz
gentoo-ab67f953d2114b604581132459ed7a9e4cbdf4df.tar.bz2
gentoo-ab67f953d2114b604581132459ed7a9e4cbdf4df.zip
sys-kernel/linux-firmware: hide mount-boot function calls behind USE flag
This will avoid unnecessary mount/umount of /boot when USE=-initramfs. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-firmware/linux-firmware-99999999.ebuild')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 6fd9059b3d55..0211e6e23f26 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -27,6 +27,7 @@ RESTRICT="binchecks strip
BDEPEND="initramfs? ( app-arch/cpio )"
+#add anything else that collides to this
RDEPEND="!savedconfig? (
redistributable? (
!sys-firmware/alsa-firmware[alsa_cards_ca0132]
@@ -71,7 +72,9 @@ RDEPEND="!savedconfig? (
)
)"
-#add anything else that collides to this
+pkg_pretend() {
+ use initramfs && mount-boot_pkg_pretend
+}
src_unpack() {
if [[ ${PV} == 99999999* ]]; then
@@ -317,7 +320,8 @@ pkg_preinst() {
ewarn "USE=savedconfig is active. You must handle file collisions manually."
fi
- mount-boot_pkg_preinst
+ # Make sure /boot is available if needed.
+ use initramfs && mount-boot_pkg_preinst
}
pkg_postinst() {
@@ -335,5 +339,16 @@ pkg_postinst() {
fi
done
- mount-boot_pkg_postinst
+ # Don't forget to umount /boot if it was previously mounted by us.
+ use initramfs && mount-boot_pkg_postinst
+}
+
+pkg_prerm() {
+ # Make sure /boot is mounted so that we can remove /boot/amd-uc.img!
+ use initramfs && mount-boot_pkg_prerm
+}
+
+pkg_postrm() {
+ # Don't forget to umount /boot if it was previously mounted by us.
+ use initramfs && mount-boot_pkg_postrm
}