summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-06-02 19:05:31 -0400
committerMike Pagano <mpagano@gentoo.org>2024-06-02 19:05:31 -0400
commit1ca207bcc4d8ca131727d4cd300c4fd5b8f53d66 (patch)
treeb015a0a06176081f0eb363b216d44dc6bed62d15 /sys-kernel/git-sources
parentsys-devel/gcc: add 15.0.0_pre20240602 (diff)
downloadgentoo-1ca207bcc4d8ca131727d4cd300c4fd5b8f53d66.tar.gz
gentoo-1ca207bcc4d8ca131727d4cd300c4fd5b8f53d66.tar.bz2
gentoo-1ca207bcc4d8ca131727d4cd300c4fd5b8f53d66.zip
sys-kernel/git-sources: add 6.10_rc2
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.10_rc2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 64cdf6753af0..e582be694b0e 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-6.9.tar.xz 144034416 BLAKE2B 4cf86c3cfe6e6534745d42dfaeca59b17ea1168c4e8b615c80e6d8aac735f11283cd85fa992b440b5d4452917e94b9f08397a64af0be5894e3df23c68892377e SHA512 fed3b4cd1fbfb4d94618587c1934273d2ecc8b6e42a3d586ff8a5f24980be930f2ef803aa2923ca3bfa5e4e619f967f3af315368f24fa76f610b10443624a579
DIST patch-6.10-rc1.patch 40674461 BLAKE2B b9d366a5370007115f070c2817a12609a214019d2213e63f15c275a0cf62f343ab999127ef3a0f5c07d6e2ac25f8787d32f3f899ba25c822d1821a3be9a6a5a6 SHA512 ef437410403c1cbf74243aaa472564808b413827acebe300a1d571685b8d596febca6f07ecf4a3f6c2a9755d0b0da047d73ef165ffb569a15e58aa1b6f0e6c08
+DIST patch-6.10-rc2.patch 40951045 BLAKE2B 45e99646253a45e4030ca70103d789e87f9d83a439875b81bd7902c6c180e41db4ac553909ac8fa109feecb303878ba3ac76ab5989430b32d196d726d81b0566 SHA512 8a326bf1f5132c6db9ca87f3d6e0d7657d33e15c64a805e56e8f6fd23df4ddd8ceb35c1059950e939f5562c3536d0981cfe560fe05fb5f7941ae23737ca630d2
diff --git a/sys-kernel/git-sources/git-sources-6.10_rc2.ebuild b/sys-kernel/git-sources/git-sources-6.10_rc2.ebuild
new file mode 100644
index 000000000000..edb1a477e11c
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.10_rc2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="6.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}