summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-07-28 16:01:42 -0400
committerMike Pagano <mpagano@gentoo.org>2019-07-28 16:01:56 -0400
commit10198f2fa86ea089d8fa14a4d92b1464de316fa2 (patch)
treee93d28cf49390af00a412634f79232c24434a91d /sys-kernel/git-sources
parentnet-libs/libvncserver: arm stable wrt bug #684596 (diff)
downloadgentoo-10198f2fa86ea089d8fa14a4d92b1464de316fa2.tar.gz
gentoo-10198f2fa86ea089d8fa14a4d92b1464de316fa2.tar.bz2
gentoo-10198f2fa86ea089d8fa14a4d92b1464de316fa2.zip
sys-kernel/git-sources: Linux patch 5.3-rc2
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.3_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 9683b9da243f..5fa506a00c50 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,2 +1,3 @@
DIST linux-5.2.tar.xz 107029708 BLAKE2B f0cf6e3a15a4bd019edbfa33cb4556d0672e807f7d139eff3ab053d0ad7649198b229475955a1f51eb90d0e9f8268cafb782f6312793fdf38472f3c6d7c2d7ee SHA512 5a28f8a34c4e0470617f5638b7112e6252109b78f23b1eed484a228530970c7ef5c130d6e5a09cf25ea2f6a0329602dcc1ec66ce893182e15b27d99bd228789c
DIST patch-5.3-rc1.patch 92211979 BLAKE2B 984990a073e8c2fed14078f10b97143d387af8e8ea678acb07251cfa9b05bb5801cc7abb43f342a0181d289fa7816b7b5ed1f13f9db2d3a28a19a0099993b531 SHA512 b48c31cb3c0a27d5bddea48bbb9805e74756d04c4f9dcf911ccb44d3e8ad128d74c52e68b510bef4997b52ddf4b69d4d359c37be6b9df478af51246d62dcff91
+DIST patch-5.3-rc2.patch 94028243 BLAKE2B 872fbe722cdc38f2a7799ea56cfa7916095d921cec841df4420b1409c2e0447e44e00cd0613e695605fd56eae24cec901b526270cf1d2616c49b937a803110cd SHA512 d3ec6cc0d4062a448a0e7470e86910d6d114b262d8dc8fa88d4e010e9a2ed6a4b1342afe49c5851121577a1b2ce83344f511157d09f339de8b3f96caaf7d2ec5
diff --git a/sys-kernel/git-sources/git-sources-5.3_rc2.ebuild b/sys-kernel/git-sources/git-sources-5.3_rc2.ebuild
new file mode 100644
index 000000000000..71a45a3201b9
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.3_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.2"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}