summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-04-17 17:48:21 -0400
committerMike Pagano <mpagano@gentoo.org>2022-04-17 17:48:21 -0400
commit09040066d538e42566a00bfcb9d5990018df9b69 (patch)
tree749f453344dcdc50b2ab13324f6ead38a2988d94 /sys-kernel/git-sources
parentapp-text/evince: Version bump to 42.2 (diff)
downloadgentoo-09040066d538e42566a00bfcb9d5990018df9b69.tar.gz
gentoo-09040066d538e42566a00bfcb9d5990018df9b69.tar.bz2
gentoo-09040066d538e42566a00bfcb9d5990018df9b69.zip
sys-kernel/git-sources: add 5.18_rc3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.18_rc3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index eb49fb6bf0c5..b443785cc7f3 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,3 +1,4 @@
DIST linux-5.17.tar.xz 128399340 BLAKE2B 82dc4a45cc25c781ac67aa6ed1e4c369544154960f41c4634d47621f381159687a227054976d078524cda28884d395a15f7542fe44ca74ce98ca6ff54a81d6d0 SHA512 89f0a7ca69d20a539d4b612a7028a30a5e98b402e4b6b88516f14237e5da4b626d7929eab8b40fccc90766e8f3bae87e9858a19077ffad20d8204acf18794f5b
DIST patch-5.18-rc1.patch 112419200 BLAKE2B 1a5b4ff89c28f3ef798b2c6f5019b6a7e04d466297d110eb7e7fb2eece3004cf514cd59ba069ba3bf8fd774d1b0f9d9708394fbab9e59f782ef01aaa6a75034b SHA512 17b29d40d56b1bf26f4cfc90c073fb588330ea1014576518bf9fdb4d71aa8eebbd0318b37616474f3b910aa5d6ac2be07cbce7493f9e4cfb88f492a9ab327053
DIST patch-5.18-rc2.patch 112841658 BLAKE2B 8419291fadcf91225db3d946ab0aa4f312101ff85653c17422d338586342acb9ed7227899fd2b4f1b1771f907f822eadf8bcff15b6d62bb9784f455ba773861f SHA512 ebab6803bfd9c3312306e97577af8dcc166fabed0bdd8e76405ee0c9118ca7cf50f83b9d2c015d2644db9206f1843142c08245f4c428f4e78d7efd0fe6024684
+DIST patch-5.18-rc3.patch 113219039 BLAKE2B 53b7e45c5d9b87286509f727e6edc3f455d2e424333e97ac75314a901d908950d84b99d7f289c825026537f4d0a34a818c346aa3c89d4a6e2335924e5a77bc67 SHA512 90c13f5584d64a4963e92ef50bd858771c92903c3c743b7b8e139c2e7a5164b997bb0b801545d732a499f3e544dd216d2717621bd21ac9962ba1850bdd32b721
diff --git a/sys-kernel/git-sources/git-sources-5.18_rc3.ebuild b/sys-kernel/git-sources/git-sources-5.18_rc3.ebuild
new file mode 100644
index 000000000000..1b58d3fd64da
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.18_rc3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.17"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}