summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-29 13:50:29 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-29 13:50:52 -0500
commitf045fbd547451ecd77730e501325ae6a097cd017 (patch)
tree45230713b0061339ef272bec7ce9774a325c337d /sys-fs
parentsys-apps/util-linux: move gen_usr_ldscript after python install (diff)
downloadgentoo-f045fbd547451ecd77730e501325ae6a097cd017.tar.gz
gentoo-f045fbd547451ecd77730e501325ae6a097cd017.tar.bz2
gentoo-f045fbd547451ecd77730e501325ae6a097cd017.zip
sys-fs/f2fs-tools: add support for musl
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild5
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild4
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.12.0-r1.ebuild4
3 files changed, 9 insertions, 4 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
index 011eaebc3a5b..ce7d7f0fa630 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,8 @@ IUSE="selinux"
RDEPEND="
sys-apps/util-linux
- selinux? ( sys-libs/libselinux )"
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )"
DEPEND="$RDEPEND"
PATCHES=( "${FILESDIR}"/${P}-fibmap-include-config_h.patch )
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
index 7d9f76759f8b..8bbde577cad3 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.11.0-r1.ebuild
@@ -14,7 +14,9 @@ SLOT="0/5"
KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 x86"
IUSE="selinux"
-RDEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )"
DEPEND="${RDEPEND}"
src_prepare() {
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.12.0-r1.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.12.0-r1.ebuild
index 523fddda1779..52fc597dc549 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-1.12.0-r1.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.12.0-r1.ebuild
@@ -14,7 +14,9 @@ SLOT="0/6"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
IUSE="selinux"
-RDEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )"
DEPEND="${RDEPEND}"
src_prepare() {