summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-04-13 22:39:07 -0400
committerMike Gilbert <floppym@gentoo.org>2024-04-13 22:47:43 -0400
commitefe2ef773c05f4e2fb3fb5fbf4d069938de12489 (patch)
treed217b05305440c4f81a79a32c217e067d39a4a9a /sys-fs
parentdev-python/opentelemetry-semantic-conventions: Remove old (diff)
downloadgentoo-efe2ef773c05f4e2fb3fb5fbf4d069938de12489.tar.gz
gentoo-efe2ef773c05f4e2fb3fb5fbf4d069938de12489.tar.bz2
gentoo-efe2ef773c05f4e2fb3fb5fbf4d069938de12489.zip
sys-fs/fuse: restrict tests unconditionally
Also add some notes. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/fuse-3.16.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-fs/fuse/fuse-3.16.2.ebuild b/sys-fs/fuse/fuse-3.16.2.ebuild
index 8b2bebb691b8..2997ce0cf204 100644
--- a/sys-fs/fuse/fuse-3.16.2.ebuild
+++ b/sys-fs/fuse/fuse-3.16.2.ebuild
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="3"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="+suid test"
-RESTRICT="!test? ( test )"
+RESTRICT="test"
PROPERTIES="test_privileged"
BDEPEND="
@@ -53,11 +53,13 @@ multilib_src_configure() {
}
src_test() {
- (
- addwrite /dev/cuse
- addwrite /dev/fuse
- multilib-minimal_src_test
- ) || die
+ # For tests to pass:
+ # sandbox must be disabled.
+ # Write access to /dev/cuse* and /dev/fuse is required.
+ # root must be a member of the portage group; CAP_DAC_OVERRIDE is dropped.
+ # TMPDIR must be short for unix socket paths.
+ local -x TMPDIR=/tmp
+ multilib-minimal_src_test
}
multilib_src_test() {