summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-23 02:23:42 +0100
committerSam James <sam@gentoo.org>2023-10-23 02:23:42 +0100
commit9d5e256f7ced00e674bfcb69b463d6a753e16202 (patch)
tree8b43eb8bcd75a10b470dd87e14161bcc2d5e9b57 /sys-fs
parentprofiles/base: stable-mask >=chromium-118[libcxx,lto,pgo] (needs LLVM 17) (diff)
downloadgentoo-9d5e256f7ced00e674bfcb69b463d6a753e16202.tar.gz
gentoo-9d5e256f7ced00e674bfcb69b463d6a753e16202.tar.bz2
gentoo-9d5e256f7ced00e674bfcb69b463d6a753e16202.zip
sys-fs/duperemove: fix musl build
Closes: https://bugs.gentoo.org/916078 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/duperemove/duperemove-0.13.ebuild4
-rw-r--r--sys-fs/duperemove/files/duperemove-0.13-musl.patch23
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.13.ebuild b/sys-fs/duperemove/duperemove-0.13.ebuild
index 82e6d1da0fdb..f984cc9d8e66 100644
--- a/sys-fs/duperemove/duperemove-0.13.ebuild
+++ b/sys-fs/duperemove/duperemove-0.13.ebuild
@@ -24,6 +24,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${P/_/.}
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
src_compile() {
emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
}
diff --git a/sys-fs/duperemove/files/duperemove-0.13-musl.patch b/sys-fs/duperemove/files/duperemove-0.13-musl.patch
new file mode 100644
index 000000000000..2fbf6782579f
--- /dev/null
+++ b/sys-fs/duperemove/files/duperemove-0.13-musl.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/916078
+https://github.com/markfasheh/duperemove/issues/310
+https://github.com/markfasheh/duperemove/commit/b275a365545a45f317280153a43bf02a55f89de6
+
+From b275a365545a45f317280153a43bf02a55f89de6 Mon Sep 17 00:00:00 2001
+From: psykose <alice@ayaya.dev>
+Date: Thu, 12 Oct 2023 08:37:47 +0000
+Subject: [PATCH] dbfile: include <sys/types.h> for dev_t
+
+fixes build on musl
+
+closes #310
+--- a/dbfile.h
++++ b/dbfile.h
+@@ -5,6 +5,7 @@
+ #include <stdint.h>
+ #include <sqlite3.h>
+ #include <stdbool.h>
++#include <sys/types.h>
+ #include "util.h"
+
+ struct filerec;
+