summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-04 18:33:52 +0100
committerSam James <sam@gentoo.org>2022-07-04 18:34:21 +0100
commit968e991786b0256ad2ec989e699a2b07e5c1c8da (patch)
tree1d99edf30e06563b38bc8388fcf1952289149228 /sys-fs
parentsys-fs/zfs: force -fno-tree-vectorize (diff)
downloadgentoo-968e991786b0256ad2ec989e699a2b07e5c1c8da.tar.gz
gentoo-968e991786b0256ad2ec989e699a2b07e5c1c8da.tar.bz2
gentoo-968e991786b0256ad2ec989e699a2b07e5c1c8da.zip
sys-fs/zfs: force -fno-tree-vectorize (backport for older versions)
Workaround issue with GCC 12 until solved upstream. Segfault occurs w/ 'zfs send' otherwise (and very possibly other commands). Let's backport for older versions to be safe after discussion w/ gyakovlev. Bug: https://github.com/openzfs/zfs/issues/13605 Bug: https://github.com/openzfs/zfs/issues/13620 Closes: https://bugs.gentoo.org/856373 See: 1cbf3fbc336adfdcd122da5b0989c2993de358dc Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs/zfs-2.0.7-r1.ebuild (renamed from sys-fs/zfs/zfs-2.0.7.ebuild)7
-rw-r--r--sys-fs/zfs/zfs-2.1.4-r1.ebuild (renamed from sys-fs/zfs/zfs-2.1.4.ebuild)7
2 files changed, 14 insertions, 0 deletions
diff --git a/sys-fs/zfs/zfs-2.0.7.ebuild b/sys-fs/zfs/zfs-2.0.7-r1.ebuild
index 2a638aee9616..68d9116fd3de 100644
--- a/sys-fs/zfs/zfs-2.0.7.ebuild
+++ b/sys-fs/zfs/zfs-2.0.7-r1.ebuild
@@ -191,6 +191,13 @@ src_configure() {
use custom-cflags || strip-flags
use minimal || python_setup
+ # All the same issue:
+ # Segfaults w/ GCC 12 and 'zfs send'
+ # bug #856373
+ # https://github.com/openzfs/zfs/issues/13620
+ # https://github.com/openzfs/zfs/issues/13605
+ append-flags -fno-tree-vectorize
+
local myconf=(
--bindir="${EPREFIX}/bin"
--enable-shared
diff --git a/sys-fs/zfs/zfs-2.1.4.ebuild b/sys-fs/zfs/zfs-2.1.4-r1.ebuild
index 465412d2cee6..fb6aab2ca7e7 100644
--- a/sys-fs/zfs/zfs-2.1.4.ebuild
+++ b/sys-fs/zfs/zfs-2.1.4-r1.ebuild
@@ -184,6 +184,13 @@ src_configure() {
use custom-cflags || strip-flags
use minimal || python_setup
+ # All the same issue:
+ # Segfaults w/ GCC 12 and 'zfs send'
+ # bug #856373
+ # https://github.com/openzfs/zfs/issues/13620
+ # https://github.com/openzfs/zfs/issues/13605
+ append-flags -fno-tree-vectorize
+
local myconf=(
--bindir="${EPREFIX}/bin"
--enable-shared