summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-21 18:04:49 +0000
committerSam James <sam@gentoo.org>2023-11-21 18:05:16 +0000
commit826a1d8d0047d01e84de3784f3f03f6842151764 (patch)
tree24b6a3eb5e109f82c5066f974d5359e95f9a79d4 /sys-fs
parentdev-libs/openssl: add 3.2.0_beta1 (unkeyworded) (diff)
downloadgentoo-826a1d8d0047d01e84de3784f3f03f6842151764.tar.gz
gentoo-826a1d8d0047d01e84de3784f3f03f6842151764.tar.bz2
gentoo-826a1d8d0047d01e84de3784f3f03f6842151764.zip
sys-fs/duperemove: 0.14 was respun
Changes are as expected. Bug: https://github.com/markfasheh/duperemove/issues/330 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/duperemove/Manifest1
-rw-r--r--sys-fs/duperemove/duperemove-0.14-r1.ebuild39
-rw-r--r--sys-fs/duperemove/files/duperemove-0.14-wformat-security.patch25
3 files changed, 65 insertions, 0 deletions
diff --git a/sys-fs/duperemove/Manifest b/sys-fs/duperemove/Manifest
index 5601fe4b57c2..1560fd7824c9 100644
--- a/sys-fs/duperemove/Manifest
+++ b/sys-fs/duperemove/Manifest
@@ -1,3 +1,4 @@
DIST duperemove-0.12.gh.tar.gz 162458 BLAKE2B 53dae9df2b45cb9ede8041e8a7a827c22c725da51d6df74acc96b464d4bfcc3a14b8adcd4b9ada68e2cf1411a5f015be27476e088a655998b0cc9d1f19acfae8 SHA512 7b5f464615f4ba850733657239dd4d68120d592424b6be56687b7ad4f6fd2dee67fd7729a1cd47c803dd77864dee033d8eef2f7f6774dc0f657b0d52aeb5559c
DIST duperemove-0.13.gh.tar.gz 165454 BLAKE2B 8bfac3448b5ee8842be77b0ac969439197050d3ef4b245be85a918353c966e56d7b7505e004af830caca50732d1227795769d803640f422a1bed8ca299802e75 SHA512 e24fa9f658acf1c1badd797af719f81250861b9af4595cf96aa3583fe558a2fba7390bc06184f6a4b6c76be3c8b214d6a6ead8b0de6914a5e1df053d5e7e24e7
+DIST duperemove-0.14.gh.new.tar.gz 167912 BLAKE2B 819a86d8846106b701164425080f33e69e6239b7c7fe5df560fdb700b7d1275491d4a53c9f8e91fb29dc5c6381ba8a3f0a202f4cde5dadb4ebce328edd5d3764 SHA512 e193af84e729eb1bfb1cd1c5b965243bbefb93e0cba192ef5389916093dc84ad9e793031ecca06dc1173a673282aa16beb4d956b1a9acfc68d15d89798067d22
DIST duperemove-0.14.gh.tar.gz 167844 BLAKE2B 3f489ca29e3417cacb186fe5d93de2d1a1052a1fc04811c8853e30430e883daaa8cce9262efbe3d6535295cc53904c2c996fda397b24601a045907c9035f6601 SHA512 3a205d2cbf92a3d9a0f48d276a153b2259514cbb2a5911d63830cc145711118642329f164464ebd6639b764a624c8f9e59b19779a36155f5709f45e59689c008
diff --git a/sys-fs/duperemove/duperemove-0.14-r1.ebuild b/sys-fs/duperemove/duperemove-0.14-r1.ebuild
new file mode 100644
index 000000000000..e08d9f8519fa
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.14-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove/"
+# XXX: drop .new on bump after 0.14, added for respin
+SRC_URI="
+ https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.gh.new.tar.gz
+"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-wformat-security.patch
+)
+
+src_compile() {
+ emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
diff --git a/sys-fs/duperemove/files/duperemove-0.14-wformat-security.patch b/sys-fs/duperemove/files/duperemove-0.14-wformat-security.patch
new file mode 100644
index 000000000000..43c946ca35fe
--- /dev/null
+++ b/sys-fs/duperemove/files/duperemove-0.14-wformat-security.patch
@@ -0,0 +1,25 @@
+https://github.com/markfasheh/duperemove/commit/5cbcc65254cf684b4281b278b5ee38c82d0a3ee5
+
+From 5cbcc65254cf684b4281b278b5ee38c82d0a3ee5 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Mon, 20 Nov 2023 21:09:58 +0000
+Subject: [PATCH] util.c: make debug helper `-Wformat-security`-clean
+
+Without the change `gcc-14` fails the build with `-Werror=format-security`
+as:
+
+ util.c:340:25: error: format not a string literal and no format arguments [-Werror=format-security]
+ 340 | fprintf(stream, buf);
+ | ^~~
+
+It's a harmless warning as `UUID` has a well-defined set of characters.
+But `fputs()` expresses intent more directly to print the string as is.
+--- a/util.c
++++ b/util.c
+@@ -337,5 +337,5 @@ void debug_print_uuid(FILE *stream, uuid_t uuid)
+ {
+ char buf[37];
+ uuid_unparse(uuid, buf);
+- fprintf(stream, buf);
++ fputs(buf, stream);
+ }