summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2018-09-30 04:34:56 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-10-01 01:01:50 -0700
commit7d85d0b5f6274597bac0d2ec8d99c8c6bf953cd5 (patch)
tree163d1b0e50d8183d8eb634ebdb4020ac1cdc7de2 /sys-fs
parentsys-fs/bees: Bump version to v0.6 (diff)
downloadgentoo-7d85d0b5f6274597bac0d2ec8d99c8c6bf953cd5.tar.gz
gentoo-7d85d0b5f6274597bac0d2ec8d99c8c6bf953cd5.tar.bz2
gentoo-7d85d0b5f6274597bac0d2ec8d99c8c6bf953cd5.zip
sys-fs/bees: Specify package version to Makefile
This works around an upstream issue in non-git ebuilds. The change is proposed to work from v0.7 onwards. It's still a hack but gets around the git error messages that show up otherwise during the ebuild phase. Closes: https://github.com/gentoo/gentoo/pull/10016 Github-Link: https://github.com/Zygo/bees/issues/75 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/bees-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index 72fef108e72d..22a1b0a48880 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -60,6 +60,11 @@ src_configure() {
LIBDIR=$(get_libdir)
DEFAULT_MAKE_TARGET=all
EOF
+ if [[ ${PV} != "9999" ]] ; then
+ cat >>localconf <<-EOF || die
+ BEES_VERSION=v${PV}
+ EOF
+ fi
if use tools; then
echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
fi