summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorFrançois Degros <fdegros@chromium.org>2023-08-14 15:00:04 +1000
committerFlorian Schmaus <flow@gentoo.org>2023-09-15 08:45:43 +0200
commit672fa1cd33337c092981722194774096aae06028 (patch)
tree2cce96151b84bed9cfd610b2575079c1df4b8416 /sys-fs
parentapp-admin/sxid: update EAPI 6 -> 8 (diff)
downloadgentoo-672fa1cd33337c092981722194774096aae06028.tar.gz
gentoo-672fa1cd33337c092981722194774096aae06028.tar.bz2
gentoo-672fa1cd33337c092981722194774096aae06028.zip
sys-fs/rar2fs: Add rar2fs 1.29.6
[flow: EAPI 8] Signed-off-by: François Degros <fdegros@chromium.org> Closes: https://github.com/gentoo/gentoo/pull/32305 Signed-off-by: Florian Schmaus <flow@gentoo.org> Modified-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/rar2fs/Manifest1
-rw-r--r--sys-fs/rar2fs/rar2fs-1.29.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/Manifest b/sys-fs/rar2fs/Manifest
index 4b33dbfeb25a..a5e6db1080aa 100644
--- a/sys-fs/rar2fs/Manifest
+++ b/sys-fs/rar2fs/Manifest
@@ -1 +1,2 @@
DIST rar2fs-1.29.5.tar.gz 268706 BLAKE2B cdc88672976c99868dedb65d772d6ad76bad7b1891845d09f575701005ab58cf79b5b19cb5de79d81bf1ef6ea8a734cd9755e002b6bf141f4166fdb73a667e2e SHA512 78962d614d66eeb09c013212d8bd373907d8a55489d9bc544f43ba1f34989cd777bba38a6af5899fea0b01e4cfdc0ee18462776e2d4cc529e05d5c6d30a899bf
+DIST rar2fs-1.29.6.tar.gz 269026 BLAKE2B df2b33561898b8e23bd54481f275058442be7b8616d7107614f98e6cc478c400ad764fff35ccab29f4a907ba9ac2afbb58f3093976e5b191b1e844f28a64f6a0 SHA512 c046f51c7047c3d04c3e9d1b69c72c019c32c70f83776f8179b608e8c21a7a3edfd4229434285a4234fd65ad48ffd5cbae3b2fa2d285cecf1a84a3a30ab3c256
diff --git a/sys-fs/rar2fs/rar2fs-1.29.6.ebuild b/sys-fs/rar2fs/rar2fs-1.29.6.ebuild
new file mode 100644
index 000000000000..fab50845ead6
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.29.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Note that upstream unrar sometimes breaks ABI without updating the SONAME
+# version so try rebuilding rar2fs if it doesn't work following an unrar
+# upgrade.
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar="${ESYSROOT}"/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}