summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2021-06-19 10:42:50 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-07 14:44:07 -0400
commit5ad5474983c2e84bd466d03f24c5040c8c853e92 (patch)
tree238ad07d7e8b9e4d50276ec343137d90651f1096 /sys-fs
parentsys-apps/systemd: add 249, drop 249_rc3 (diff)
downloadgentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.tar.gz
gentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.tar.bz2
gentoo-5ad5474983c2e84bd466d03f24c5040c8c853e92.zip
sys-fs/bees: Drop conflicting musl hack + small fixes in 9999
An upcoming musl update will add the missing function. Also: * Fix installation with eprefix * Fix style * Inherit toolchain-funcs (for tc-export) Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/bees-9999.ebuild15
-rw-r--r--sys-fs/bees/files/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch50
2 files changed, 6 insertions, 59 deletions
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index d656c4e6cded..7777d0ea45fd 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info systemd
+inherit linux-info systemd toolchain-funcs
DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
HOMEPAGE="https://github.com/Zygo/bees"
@@ -29,8 +29,6 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~BTRFS_FS"
ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
-PATCHES=( "${FILESDIR}/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch" )
-
pkg_pretend() {
if [[ ${MERGE_TYPE} != buildonly ]]; then
if kernel_is -lt 4 11; then
@@ -74,17 +72,16 @@ src_prepare() {
}
src_configure() {
+ tc-export CC CXX AR
cat >localconf <<-EOF || die
- LIBEXEC_PREFIX=/usr/libexec
- PREFIX=/usr
- LIBDIR="$(get_libdir)"
+ LIBEXEC_PREFIX="${EPREFIX}/usr/libexec"
+ PREFIX="${EPREFIX}/usr"
+ LIBDIR="${EPREFIX}/$(get_libdir)"
SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
DEFAULT_MAKE_TARGET=all
EOF
if [[ ${PV} != "9999" ]] ; then
- cat >>localconf <<-EOF || die
- BEES_VERSION=v${PV}
- EOF
+ echo BEES_VERSION=v${PV} >>localconf || die
fi
if use tools; then
echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
diff --git a/sys-fs/bees/files/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch b/sys-fs/bees/files/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch
deleted file mode 100644
index 6b8224a5a56f..000000000000
--- a/sys-fs/bees/files/v9999-0001-HACK-musl-does-not-define-pthread_getname_np.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 02bdb636be5abd15836e5e43e9b53517595686c9 Mon Sep 17 00:00:00 2001
-From: Kai Krakow <kai@kaishome.de>
-Date: Thu, 16 Apr 2020 21:21:57 +0200
-Subject: [PATCH v9999] HACK: musl does not define pthread_getname_np()
-
-The glibc alternative musl does not define this setter function. This
-fix is probably wrong because it resets the thread names used for
-logging internally to empty strings.
-
-Link: https://www.openwall.com/lists/musl/2019/07/17/3
-Signed-off-by: Kai Krakow <kai@kaishome.de>
----
- lib/task.cc | 2 ++
- src/bees.cc | 2 ++
- 2 files changed, 4 insertions(+)
-
-diff --git a/lib/task.cc b/lib/task.cc
-index 937a477..85da59b 100644
---- a/lib/task.cc
-+++ b/lib/task.cc
-@@ -194,7 +194,9 @@ namespace crucible {
- lock.unlock();
-
- char buf[24] = { 0 };
-+#ifdef _GNU_SOURCE
- DIE_IF_MINUS_ERRNO(pthread_getname_np(pthread_self(), buf, sizeof(buf)));
-+#endif
- DIE_IF_MINUS_ERRNO(pthread_setname_np(pthread_self(), m_title.c_str()));
-
- sched_param param = { .sched_priority = 0 };
-diff --git a/src/bees.cc b/src/bees.cc
-index 03a626c..3db5d73 100644
---- a/src/bees.cc
-+++ b/src/bees.cc
-@@ -152,10 +152,12 @@ BeesNote::get_name()
- // OK try the pthread name next.
- char buf[24];
- memset(buf, '\0', sizeof(buf));
-+#ifdef _GNU_SOURCE
- int err = pthread_getname_np(pthread_self(), buf, sizeof(buf));
- if (err) {
- return string("pthread_getname_np: ") + strerror(err);
- }
-+#endif
- buf[sizeof(buf) - 1] = '\0';
-
- // thread_getname_np returns process name
---
-2.26.2
-