summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-13 10:39:22 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 18:53:45 +0300
commit4272e61cd29e33ad3d9b997eba147715fcf12364 (patch)
treee6c6025a907e0df6a58b5a80d8e5d5504e543688 /sys-fs
parentsys-fs/udev: use python_has_version (diff)
downloadgentoo-4272e61cd29e33ad3d9b997eba147715fcf12364.tar.gz
gentoo-4272e61cd29e33ad3d9b997eba147715fcf12364.tar.bz2
gentoo-4272e61cd29e33ad3d9b997eba147715fcf12364.zip
sys-fs/unionfs-fuse: use python_has_version
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild7
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild5
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.2.ebuild7
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild5
4 files changed, 14 insertions, 10 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
index 329020ca1173..3d24e51be9c0 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -17,7 +17,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
)
@@ -29,7 +30,7 @@ pkg_setup() {
python_check_deps() {
use test || return 0
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
src_compile() {
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild
index 2312fa71e7c0..fd834c3d1aa3 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild
@@ -17,7 +17,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
)
@@ -29,7 +30,7 @@ pkg_setup() {
python_check_deps() {
use test || return 0
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
src_compile() {
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.2.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.2.ebuild
index 329020ca1173..3d24e51be9c0 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.2.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -17,7 +17,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
)
@@ -29,7 +30,7 @@ pkg_setup() {
python_check_deps() {
use test || return 0
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
src_compile() {
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index eab277c33f84..a3bab99e2460 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -17,7 +17,8 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="sys-fs/fuse:0"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
)
@@ -29,7 +30,7 @@ pkg_setup() {
python_check_deps() {
use test || return 0
- has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
src_compile() {