summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2024-06-09 17:17:01 -0700
committerZac Medico <zmedico@gentoo.org>2024-06-09 17:43:57 -0700
commit340671b3ef2d93d98fbc49ea23dd3ca76bb86d98 (patch)
treef6bbc12fd5529ae7b569b2edb6c129ab5ea56a59 /sys-fs
parentprofiles/arch: drop qt6 use.stable.mask where possible (diff)
downloadgentoo-340671b3ef2d93d98fbc49ea23dd3ca76bb86d98.tar.gz
gentoo-340671b3ef2d93d98fbc49ea23dd3ca76bb86d98.tar.bz2
gentoo-340671b3ef2d93d98fbc49ea23dd3ca76bb86d98.zip
sys-fs/linux-apfs-rw: new package, add 0.3.9
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/linux-apfs-rw/Manifest1
-rw-r--r--sys-fs/linux-apfs-rw/linux-apfs-rw-0.3.9.ebuild40
-rw-r--r--sys-fs/linux-apfs-rw/metadata.xml11
3 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/linux-apfs-rw/Manifest b/sys-fs/linux-apfs-rw/Manifest
new file mode 100644
index 000000000000..09edd1b8f6dc
--- /dev/null
+++ b/sys-fs/linux-apfs-rw/Manifest
@@ -0,0 +1 @@
+DIST linux-apfs-rw-0.3.9.tar.gz 209682 BLAKE2B 663007f1b7c7af6cf4198066b6ba141c3bb625685508fe06f72bb3654438bac03ecc50204227fd724d16a4bb757f0df9ed7d19fb08fece8b98f08da9cfb3c8f5 SHA512 b241044c6faa175c1523f0ba391f9bb9ba336b3c39fd3528f43e0df5e9c6090691ab226091948f9f32f33748e8c435a0881ccc00fed4badca97d195c1982f9a7
diff --git a/sys-fs/linux-apfs-rw/linux-apfs-rw-0.3.9.ebuild b/sys-fs/linux-apfs-rw/linux-apfs-rw-0.3.9.ebuild
new file mode 100644
index 000000000000..5d6a55ecd6d9
--- /dev/null
+++ b/sys-fs/linux-apfs-rw/linux-apfs-rw-0.3.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="APFS module for linux, with experimental write support"
+HOMEPAGE="https://github.com/linux-apfs/linux-apfs-rw"
+SRC_URI="https://github.com/linux-apfs/linux-apfs-rw/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+CONFIG_CHECK="LIBCRC32C"
+
+pkg_setup() {
+ linux-mod-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed -e "s/GIT_COMMIT=.*/GIT_COMMIT=${PV}/" -i genver.sh || die
+}
+
+src_compile() {
+ local modlist=( apfs=extra )
+ local modargs=( KERNEL_DIR=${KV_OUT_DIR} KERNELRELEASE=${KV_FULL} )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ linux-mod-r1_src_install
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+}
diff --git a/sys-fs/linux-apfs-rw/metadata.xml b/sys-fs/linux-apfs-rw/metadata.xml
new file mode 100644
index 000000000000..313f7d9cb420
--- /dev/null
+++ b/sys-fs/linux-apfs-rw/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">linux-apfs/linux-apfs-rw</remote-id>
+ </upstream>
+</pkgmetadata>