summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-24 11:12:03 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-24 11:14:28 -0400
commit29f1e814f6c781e3809710b8b9a75024639ec0bf (patch)
tree0bdd80d1b7295cd8976526c07f7f8b8bdf73cc59 /sys-fs
parentdev-ml/ppx_bin_prot: 0.15.0 bump (diff)
downloadgentoo-29f1e814f6c781e3809710b8b9a75024639ec0bf.tar.gz
gentoo-29f1e814f6c781e3809710b8b9a75024639ec0bf.tar.bz2
gentoo-29f1e814f6c781e3809710b8b9a75024639ec0bf.zip
sys-fs/lvm2: pass systemdutildir to make install
configure always calls pkg-config, and offers no way to override this variable. We need to call pkg-config with PKG_CONFIG_FDO_SYSROOT_RULES set to avoid duplicating SYSROOT in the install paths. systemd_get_utildir takes care of that for us. Closes: https://bugs.gentoo.org/840577 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lvm2/lvm2-2.02.188-r2.ebuild12
-rw-r--r--sys-fs/lvm2/lvm2-2.03.14-r1.ebuild10
2 files changed, 9 insertions, 13 deletions
diff --git a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
index 60cc0d980580..a3e76755f1d5 100644
--- a/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.188-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -207,14 +207,12 @@ src_compile() {
}
src_install() {
- local inst INSTALL_TARGETS
- INSTALL_TARGETS=( install install_tmpfiles_configuration )
+ local inst
+ local INSTALL_TARGETS=( install install_tmpfiles_configuration )
# install systemd related files only when requested, bug #522430
- use systemd && INSTALL_TARGETS+=( install_systemd_units install_systemd_generators )
+ use systemd && INSTALL_TARGETS+=( systemdutildir="$(systemd_get_utildir)" install_systemd_units install_systemd_generators )
use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
- for inst in ${INSTALL_TARGETS[@]}; do
- emake V=1 DESTDIR="${D}" ${inst}
- done
+ emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper
diff --git a/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild b/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild
index 2ea2eaea55a6..47a08cc12e78 100644
--- a/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.14-r1.ebuild
@@ -206,14 +206,12 @@ src_compile() {
}
src_install() {
- local inst INSTALL_TARGETS
- INSTALL_TARGETS=( install install_tmpfiles_configuration )
+ local inst
+ local INSTALL_TARGETS=( install install_tmpfiles_configuration )
# install systemd related files only when requested, bug #522430
- use systemd && INSTALL_TARGETS+=( install_systemd_units install_systemd_generators )
+ use systemd && INSTALL_TARGETS+=( systemdutildir="$(systemd_get_utildir)" install_systemd_units install_systemd_generators )
use device-mapper-only && INSTALL_TARGETS=( install_device-mapper )
- for inst in ${INSTALL_TARGETS[@]}; do
- emake V=1 DESTDIR="${D}" ${inst}
- done
+ emake V=1 DESTDIR="${D}" "${INSTALL_TARGETS[@]}"
newinitd "${FILESDIR}"/device-mapper.rc-2.02.105-r2 device-mapper
newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper