summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-09-26 01:04:22 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-09-26 01:08:17 -0700
commit4d825be7c42f1a6a024ddee07c016e074d2684c7 (patch)
treeb0309529feecfdf7df91712224653c6cd720dcd9 /sys-fs/mtd-utils
parentsys-fs/snapraid: drop 11.6 (diff)
downloadgentoo-4d825be7c42f1a6a024ddee07c016e074d2684c7.tar.gz
gentoo-4d825be7c42f1a6a024ddee07c016e074d2684c7.tar.bz2
gentoo-4d825be7c42f1a6a024ddee07c016e074d2684c7.zip
sys-fs/mtd-utils: improve configure opts
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/940249
Diffstat (limited to 'sys-fs/mtd-utils')
-rw-r--r--sys-fs/mtd-utils/metadata.xml3
-rw-r--r--sys-fs/mtd-utils/mtd-utils-2.2.1-r1.ebuild (renamed from sys-fs/mtd-utils/mtd-utils-2.2.1.ebuild)14
2 files changed, 13 insertions, 4 deletions
diff --git a/sys-fs/mtd-utils/metadata.xml b/sys-fs/mtd-utils/metadata.xml
index 85989de1c9ac..1a40eb3fdbdb 100644
--- a/sys-fs/mtd-utils/metadata.xml
+++ b/sys-fs/mtd-utils/metadata.xml
@@ -12,4 +12,7 @@
<upstream>
<remote-id type="cpe">cpe:/a:mtd-utils_project:mtd-utils</remote-id>
</upstream>
+ <use>
+ <flag name="ubifs">Build UBIFS tools</flag>
+ </use>
</pkgmetadata>
diff --git a/sys-fs/mtd-utils/mtd-utils-2.2.1.ebuild b/sys-fs/mtd-utils/mtd-utils-2.2.1-r1.ebuild
index bdc80fbd7c37..cedbe3c1639e 100644
--- a/sys-fs/mtd-utils/mtd-utils-2.2.1.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-2.2.1-r1.ebuild
@@ -12,7 +12,8 @@ SRC_URI="https://infraroot.at/pub/mtd/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="+lzo +ssl test xattr +zstd"
+IUSE="+lzo +ssl test xattr +zstd ubifs"
+REQUIRED_USE="ubifs? ( lzo ssl xattr zstd )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -34,14 +35,19 @@ src_prepare() {
}
src_configure() {
- # --enable-tests is for test programs that are installed
+ # --with-tests is for test programs that are installed; was --enable-tests in earlier versions
local myeconfargs=(
- --enable-tests
+ --with-tests
+ --with-zlib
+ --enable-ubihealthd
+ --with-lsmtd
+ --with-jffs
$(use_enable test unit-tests)
$(use_with lzo)
- $(use_with ssl ubifs)
$(use_with xattr)
$(use_with zstd)
+ $(use_with ubifs)
+ $(use_with ubifs crypto) # UBIFS-specific crypto support
)
econf "${myeconfargs[@]}"
}