summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-07-29 13:50:43 -0400
committerMike Gilbert <floppym@gentoo.org>2019-07-29 13:50:54 -0400
commit03e113f278c810446e7b480eef59c23df5455d5f (patch)
tree7f514e77c094bc215b5ca48609175cc5602b77ad /sys-fs/eudev
parentsys-power/acpilight: Update remote in metadata.xml (diff)
downloadgentoo-03e113f278c810446e7b480eef59c23df5455d5f.tar.gz
gentoo-03e113f278c810446e7b480eef59c23df5455d5f.tar.bz2
gentoo-03e113f278c810446e7b480eef59c23df5455d5f.zip
sys-fs/eudev: use acct-group packages
Package-Manager: Portage-2.3.69_p3, Repoman-2.3.16_p12 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs/eudev')
-rw-r--r--sys-fs/eudev/eudev-3.2.5.ebuild13
-rw-r--r--sys-fs/eudev/eudev-3.2.7-r2.ebuild12
-rw-r--r--sys-fs/eudev/eudev-3.2.8.ebuild12
-rw-r--r--sys-fs/eudev/eudev-4.9999.ebuild11
-rw-r--r--sys-fs/eudev/eudev-9999.ebuild12
5 files changed, 21 insertions, 39 deletions
diff --git a/sys-fs/eudev/eudev-3.2.5.ebuild b/sys-fs/eudev/eudev-3.2.5.ebuild
index d84528595794..292095d63780 100644
--- a/sys-fs/eudev/eudev-3.2.5.ebuild
+++ b/sys-fs/eudev/eudev-3.2.5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
KV_min=2.6.39
-inherit autotools linux-info multilib multilib-minimal user
+inherit autotools linux-info multilib multilib-minimal
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
@@ -39,6 +39,9 @@ DEPEND="${COMMON_DEPEND}
test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
@@ -184,12 +187,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
- # https://bugs.gentoo.org/246847
- # https://bugs.gentoo.org/514174
- enewgroup input
-
- # REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.
local rv rvres=doitnew
diff --git a/sys-fs/eudev/eudev-3.2.7-r2.ebuild b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
index 9ab6b6a42a2c..a9b3e55a1b92 100644
--- a/sys-fs/eudev/eudev-3.2.7-r2.ebuild
+++ b/sys-fs/eudev/eudev-3.2.7-r2.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
KV_min=2.6.39
-inherit autotools linux-info multilib multilib-minimal user
+inherit autotools linux-info multilib multilib-minimal
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
@@ -39,6 +39,9 @@ DEPEND="${COMMON_DEPEND}
test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
@@ -186,13 +189,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
- # https://bugs.gentoo.org/246847
- # https://bugs.gentoo.org/514174
- enewgroup input
- enewgroup kvm 78
- enewgroup render
-
# REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.
diff --git a/sys-fs/eudev/eudev-3.2.8.ebuild b/sys-fs/eudev/eudev-3.2.8.ebuild
index 9ab6b6a42a2c..a9b3e55a1b92 100644
--- a/sys-fs/eudev/eudev-3.2.8.ebuild
+++ b/sys-fs/eudev/eudev-3.2.8.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
KV_min=2.6.39
-inherit autotools linux-info multilib multilib-minimal user
+inherit autotools linux-info multilib multilib-minimal
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
@@ -39,6 +39,9 @@ DEPEND="${COMMON_DEPEND}
test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
@@ -186,13 +189,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
- # https://bugs.gentoo.org/246847
- # https://bugs.gentoo.org/514174
- enewgroup input
- enewgroup kvm 78
- enewgroup render
-
# REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.
diff --git a/sys-fs/eudev/eudev-4.9999.ebuild b/sys-fs/eudev/eudev-4.9999.ebuild
index a2f3610f835c..da2372754cf1 100644
--- a/sys-fs/eudev/eudev-4.9999.ebuild
+++ b/sys-fs/eudev/eudev-4.9999.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
KV_min=2.6.39
-inherit autotools linux-info multilib multilib-minimal user
+inherit autotools linux-info multilib multilib-minimal
if [[ ${PV} = 4.9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
@@ -40,6 +40,9 @@ DEPEND="${COMMON_DEPEND}
test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
@@ -178,12 +181,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
- # https://bugs.gentoo.org/246847
- # https://bugs.gentoo.org/514174
- enewgroup input
-
- # REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.
local rv rvres=doitnew
diff --git a/sys-fs/eudev/eudev-9999.ebuild b/sys-fs/eudev/eudev-9999.ebuild
index 9ab6b6a42a2c..a9b3e55a1b92 100644
--- a/sys-fs/eudev/eudev-9999.ebuild
+++ b/sys-fs/eudev/eudev-9999.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
KV_min=2.6.39
-inherit autotools linux-info multilib multilib-minimal user
+inherit autotools linux-info multilib multilib-minimal
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/gentoo/eudev.git"
@@ -39,6 +39,9 @@ DEPEND="${COMMON_DEPEND}
test? ( app-text/tree dev-lang/perl )"
RDEPEND="${COMMON_DEPEND}
+ acct-group/input
+ acct-group/kvm
+ acct-group/render
!<sys-fs/lvm2-2.02.103
!<sec-policy/selinux-base-2.20120725-r10
!sys-fs/udev
@@ -186,13 +189,6 @@ pkg_postinst() {
ewarn "else losetup may be confused when looking for unused devices."
fi
- # https://cgit.freedesktop.org/systemd/systemd/commit/rules/50-udev-default.rules?id=3dff3e00e044e2d53c76fa842b9a4759d4a50e69
- # https://bugs.gentoo.org/246847
- # https://bugs.gentoo.org/514174
- enewgroup input
- enewgroup kvm 78
- enewgroup render
-
# REPLACING_VERSIONS should only ever have zero or 1 values but in case it doesn't,
# process it as a list. We only care about the zero case (new install) or the case where
# the same version is being re-emerged. If there is a second version, allow it to abort.