summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-07-28 20:11:27 -0700
committerMatt Turner <mattst88@gentoo.org>2020-07-28 22:38:15 -0700
commitaef2b204ecdc156fed875b5cb4f2b3ec66095f32 (patch)
treecfdd2e796d93abcbe546e02ffe83076df3cba228 /sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild
parentnet-irc/irker: ppc64 keyworded (bug #734340) (diff)
downloadgentoo-aef2b204ecdc156fed875b5cb4f2b3ec66095f32.tar.gz
gentoo-aef2b204ecdc156fed875b5cb4f2b3ec66095f32.tar.bz2
gentoo-aef2b204ecdc156fed875b5cb4f2b3ec66095f32.zip
sys-firmware/sof-firmware: Version bump to 1.5.1
Clsoes: https://bugs.gentoo.org/733254 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild')
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild b/sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild
new file mode 100644
index 000000000000..cfd84283ad7a
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-1.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/archive/stable-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S=${WORKDIR}/sof-bin-stable-v${PV}
+
+src_compile() {
+ sed -i -e '1i #!/bin/bash\nset -e' \
+ -e '/^ROOT=/d' \
+ -e "s/^VERSION=.*/VERSION=v${PV}/" go.sh || die
+}
+
+src_install() {
+ mkdir -p ${D}/lib/firmware || die
+ ROOT=${D} ${S}/go.sh || die
+}