summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/sigrok-firmware-fx2lafw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/sigrok-firmware-fx2lafw')
-rw-r--r--sys-firmware/sigrok-firmware-fx2lafw/Manifest2
-rw-r--r--sys-firmware/sigrok-firmware-fx2lafw/metadata.xml8
-rw-r--r--sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-0.1.2.ebuild47
-rw-r--r--sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-9999.ebuild47
4 files changed, 104 insertions, 0 deletions
diff --git a/sys-firmware/sigrok-firmware-fx2lafw/Manifest b/sys-firmware/sigrok-firmware-fx2lafw/Manifest
new file mode 100644
index 000000000000..1d914d3903f3
--- /dev/null
+++ b/sys-firmware/sigrok-firmware-fx2lafw/Manifest
@@ -0,0 +1,2 @@
+DIST sigrok-firmware-fx2lafw-0.1.2.tar.gz 148798 SHA256 85c658f851fd90089382756b4c5f0326f96d630a0ad5637455a84a4a058b3572 SHA512 b1f90e06227dcd3832bb61267ef8d20a7b4df702228b884c13725e472ed56bd971a46e2b4104bde666abc599edbe20cdbb51e30ee423b07c27ab1093de5953df WHIRLPOOL bbe4705b39424c86f92ecef4d4b13e1fbf21c27e306edc8674358fc6c62a665c35753d58c53dc8177fb939443029f83ac33f1c97db66829be304919b2ffd83f1
+DIST sigrok-firmware-fx2lafw-bin-0.1.2.tar.gz 36486 SHA256 f28d411240a2f460d334e89ad18f5a632fa2a0f4afa25e030a26b41200351c70 SHA512 74d52e5200886ba3328f411e46419ed6d6892fe2ba6c0f66a94b19be82f7d04837d8a41093d1c14ce73609f84f6277956c9c44febab8a7f150c32ba7f7ab28b1 WHIRLPOOL 039a803d8e8177e731435276b03816910fba35ed51d0ac744bdff1df1ef603a728bb2046a5f057fa135ac648eb9f2c838ec16d345b1961e1fc28f411836f378e
diff --git a/sys-firmware/sigrok-firmware-fx2lafw/metadata.xml b/sys-firmware/sigrok-firmware-fx2lafw/metadata.xml
new file mode 100644
index 000000000000..fa2c363f6fec
--- /dev/null
+++ b/sys-firmware/sigrok-firmware-fx2lafw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+<use>
+ <flag name='binary'>Use official upstream pre-built binaries</flag>
+</use>
+</pkgmetadata>
diff --git a/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-0.1.2.ebuild b/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-0.1.2.ebuild
new file mode 100644
index 000000000000..6b007eda214e
--- /dev/null
+++ b/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-0.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="binary? ( http://sigrok.org/download/binary/${PN}/${PN}-bin-${PV}.tar.gz )
+ !binary? ( http://sigrok.org/download/source/${PN}/${P}.tar.gz )"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="open-source firmware for Cypress FX2 chips which makes them usable as simple logic analyzer hardware"
+HOMEPAGE="http://sigrok.org/wiki/Fx2lafw"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="binary"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ !binary? ( >=dev-embedded/sdcc-2.9.0 )"
+
+src_unpack() {
+ [[ ${PV} == "9999" ]] && git-2_src_unpack || default
+ # The binary & source dirs are slightly diff.
+ use binary && S="${WORKDIR}/${PN}-bin-${PV}"
+}
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_install() {
+ if use binary ; then
+ insinto /usr/share/sigrok-firmware
+ doins *.fw
+ dodoc ChangeLog NEWS README
+ else
+ default
+ fi
+}
diff --git a/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-9999.ebuild b/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-9999.ebuild
new file mode 100644
index 000000000000..6b007eda214e
--- /dev/null
+++ b/sys-firmware/sigrok-firmware-fx2lafw/sigrok-firmware-fx2lafw-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://sigrok.org/${PN}"
+ inherit git-2 autotools
+else
+ SRC_URI="binary? ( http://sigrok.org/download/binary/${PN}/${PN}-bin-${PV}.tar.gz )
+ !binary? ( http://sigrok.org/download/source/${PN}/${P}.tar.gz )"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="open-source firmware for Cypress FX2 chips which makes them usable as simple logic analyzer hardware"
+HOMEPAGE="http://sigrok.org/wiki/Fx2lafw"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="binary"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ !binary? ( >=dev-embedded/sdcc-2.9.0 )"
+
+src_unpack() {
+ [[ ${PV} == "9999" ]] && git-2_src_unpack || default
+ # The binary & source dirs are slightly diff.
+ use binary && S="${WORKDIR}/${PN}-bin-${PV}"
+}
+
+src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_install() {
+ if use binary ; then
+ insinto /usr/share/sigrok-firmware
+ doins *.fw
+ dodoc ChangeLog NEWS README
+ else
+ default
+ fi
+}